summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py21
1 files changed, 21 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100755
index 0000000..9c50c54
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,21 @@
+#!/usr/bin/env python
+
+import sys
+
+from distutils.core import setup
+
+# this affects the names of all the directories we do stuff with
+sys.path.insert(0, './')
+from layman.version import VERSION
+
+
+setup(name = 'layman',
+ version = VERSION,
+ description = 'Python script for retrieving gentoo overlays',
+ author = 'Gunnar Wrobel',
+ author_email = 'wrobel@gentoo.org',
+ url = 'http://projects.gunnarwrobel.de/scripts',
+ packages = ['layman', 'layman.overlays'],
+ scripts = ['bin/layman'],
+ license = 'GPL',
+ )