summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py22
1 files changed, 22 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100755
index 0000000..a8c0457
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,22 @@
+#!/usr/bin/env python
+
+import sys
+
+from distutils.core import setup
+
+# this affects the names of all the directories we do stuff with
+sys.path.insert(0, './')
+from layman.version import VERSION
+
+
+setup(name = 'layman',
+ version = VERSION,
+ description = 'Python script for retrieving gentoo overlays',
+ author = 'Gunnar Wrobel, Brian Dolbec',
+ author_email = 'wrobel@gentoo.org, brian.dolbec@gmail.com',
+ url = 'http://layman.sourceforge.net/, ' +\
+ 'http://git.overlays.gentoo.org/gitweb/?p=proj/layman.git;a=summary',
+ packages = ['layman', 'layman.overlays'],
+ scripts = ['bin/layman'],
+ license = 'GPL',
+ )