summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2007-04-20 21:53:37 +0000
committerZac Medico <zmedico@gentoo.org>2007-04-20 21:53:37 +0000
commit605060d301bad5b5564953824519bfe75f5f1dc8 (patch)
tree89015746d17c93e851a958eee33461a90d9ec752
parente45dadd04b850c9af0b20b5d19d7c89d4a935b0d (diff)
downloadportage-605060d301bad5b5564953824519bfe75f5f1dc8.tar.gz
portage-605060d301bad5b5564953824519bfe75f5f1dc8.tar.bz2
portage-605060d301bad5b5564953824519bfe75f5f1dc8.zip
For bug #175344, handle a potential InvalidDependString exception when parsing PROVIDE. (trunk r6420:6421)
svn path=/main/branches/2.1.2/; revision=6422
-rwxr-xr-xbin/repoman10
1 files changed, 8 insertions, 2 deletions
diff --git a/bin/repoman b/bin/repoman
index 1e2f54864..3eef5c29d 100755
--- a/bin/repoman
+++ b/bin/repoman
@@ -999,8 +999,14 @@ for x in scanlist:
#for x in myaux[allvars.index("RESTRICT")].split():
# if x.startswith("no"):
# print "Bad RESTRICT value: %s" % x
-
- myaux["PROVIDE"] = portage_dep.use_reduce(portage_dep.paren_reduce(myaux["PROVIDE"]), matchall=1)
+ try:
+ myaux["PROVIDE"] = portage_dep.use_reduce(
+ portage_dep.paren_reduce(myaux["PROVIDE"]), matchall=1)
+ except portage_exception.InvalidDependString, e:
+ stats["PROVIDE.syntax"] = stats["PROVIDE.syntax"] + 1
+ fails["PROVIDE.syntax"].append(mykey+".ebuild PROVIDE: "+str(e))
+ del e
+ continue
myaux["PROVIDE"] = " ".join(portage.flatten(myaux["PROVIDE"]))
for myprovide in myaux["PROVIDE"].split():
prov_cp = portage.dep_getkey(myprovide)