summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2008-06-25 07:49:58 +0000
committerZac Medico <zmedico@gentoo.org>2008-06-25 07:49:58 +0000
commit07a6c1c7d78e405be435221800eeddcc474d4b7f (patch)
treea36a611d2b44ca7bc644f28fdd413f85bb949387
parent1bea73be86683493c2db0889be82f9c92fe423d5 (diff)
downloadportage-07a6c1c7d78e405be435221800eeddcc474d4b7f.tar.gz
portage-07a6c1c7d78e405be435221800eeddcc474d4b7f.tar.bz2
portage-07a6c1c7d78e405be435221800eeddcc474d4b7f.zip
Use os.listdir() instead of portage.listdir() to avoid needless caching
of directories that only need to be listed once. svn path=/main/trunk/; revision=10779
-rw-r--r--pym/portage/dbapi/vartree.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/pym/portage/dbapi/vartree.py b/pym/portage/dbapi/vartree.py
index 835892722..80738662f 100644
--- a/pym/portage/dbapi/vartree.py
+++ b/pym/portage/dbapi/vartree.py
@@ -1490,7 +1490,7 @@ class dblink(object):
# name of the dir; the package may have been moved.
myebuildpath = None
ebuild_phase = "prerm"
- mystuff = listdir(self.dbdir, EmptyOnError=1)
+ mystuff = os.listdir(self.dbdir)
for x in mystuff:
if x.endswith(".ebuild"):
myebuildpath = os.path.join(self.dbdir, self.pkg + ".ebuild")
@@ -2522,7 +2522,7 @@ class dblink(object):
return a
# copy "info" files (like SLOT, CFLAGS, etc.) into the database
- for x in listdir(inforoot):
+ for x in os.listdir(inforoot):
self.copyfile(inforoot+"/"+x)
# write local package counter for recording