summaryrefslogtreecommitdiffstats
path: root/bin/ebuild.sh
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2007-11-21 10:45:53 +0000
committerZac Medico <zmedico@gentoo.org>2007-11-21 10:45:53 +0000
commit096443b81050a33f840b381f37617709c0813ba6 (patch)
treedf693a7c05e7f4c43f71e036e610034ee08ff3a3 /bin/ebuild.sh
parentc50a815c63f1c527fa0c38030e0de861f09a74f0 (diff)
downloadportage-096443b81050a33f840b381f37617709c0813ba6.tar.gz
portage-096443b81050a33f840b381f37617709c0813ba6.tar.bz2
portage-096443b81050a33f840b381f37617709c0813ba6.zip
In dyn_install(), don't cleanse S from the global environment,
in case the user wants to repeat the phase (like with FEATURES=noauto and the ebuild command). Only cleanse it from environment.bz2. (trunk r8583) svn path=/main/branches/2.1.2/; revision=8584
Diffstat (limited to 'bin/ebuild.sh')
-rwxr-xr-xbin/ebuild.sh14
1 files changed, 9 insertions, 5 deletions
diff --git a/bin/ebuild.sh b/bin/ebuild.sh
index bed192034..40f34a65f 100755
--- a/bin/ebuild.sh
+++ b/bin/ebuild.sh
@@ -1021,11 +1021,15 @@ dyn_install() {
# local variables can leak into the saved environment.
unset f
- # To avoid environment bloat, cleanse variables that are
- # are no longer needed after src_install().
- unset S
-
- save_ebuild_env > environment
+ (
+ # To avoid environment.bz2 bloat, cleanse variables that are
+ # are no longer needed after src_install(). Don't cleanse from
+ # the global environment though, in case the user wants to repeat
+ # this phase (like with FEATURES=noauto and the ebuild command).
+ unset S
+
+ save_ebuild_env > environment
+ )
bzip2 -f9 environment
cp "${EBUILD}" "${PF}.ebuild"