summaryrefslogtreecommitdiffstats
path: root/bin/ebuild.sh
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2009-03-23 00:57:29 +0000
committerZac Medico <zmedico@gentoo.org>2009-03-23 00:57:29 +0000
commit4aa2f3a510c829b5a34a3fab1feae306c437fbce (patch)
treeb309db4aa6043ef8a109290a7ec4cea05a71863f /bin/ebuild.sh
parent82290f6d95c42c5b5d76b3256c55b67edccf99e3 (diff)
downloadportage-4aa2f3a510c829b5a34a3fab1feae306c437fbce.tar.gz
portage-4aa2f3a510c829b5a34a3fab1feae306c437fbce.tar.bz2
portage-4aa2f3a510c829b5a34a3fab1feae306c437fbce.zip
Use a separate if/then to group boolean or'd expressions together, rather
than a subshell. svn path=/main/trunk/; revision=13149
Diffstat (limited to 'bin/ebuild.sh')
-rwxr-xr-xbin/ebuild.sh12
1 files changed, 6 insertions, 6 deletions
diff --git a/bin/ebuild.sh b/bin/ebuild.sh
index f548a8f05..79db02cf3 100755
--- a/bin/ebuild.sh
+++ b/bin/ebuild.sh
@@ -1862,12 +1862,11 @@ if ! hasq "$EBUILD_PHASE" clean cleanrm depend && \
unset PORTAGE_SANDBOX_ON
fi
-if ! hasq "$EBUILD_PHASE" clean cleanrm && \
- (
- hasq ${EBUILD_PHASE} depend || \
- [[ ! -f $T/environment || -f $PORTAGE_BUILDDIR/.ebuild_changed ]] || \
- hasq noauto ${FEATURES}
- ) ; then
+if ! hasq "$EBUILD_PHASE" clean cleanrm ; then
+if [[ $EBUILD_PHASE = depend || ! -f $T/environment || \
+ -f $PORTAGE_BUILDDIR/.ebuild_changed ]] || \
+ hasq noauto $FEATURES ; then
+
# The bashrcs get an opportunity here to set aliases that will be expanded
# during sourcing of ebuilds and eclasses.
source_all_bashrcs
@@ -1907,6 +1906,7 @@ if ! hasq "$EBUILD_PHASE" clean cleanrm && \
# This needs to be exported since prepstrip is a separate shell script.
[[ -n $QA_PRESTRIPPED ]] && export QA_PRESTRIPPED
fi
+fi
# Set default EAPI if necessary, so that most
# code can simply assume that it's defined.