summaryrefslogtreecommitdiffstats
path: root/bin/ebuild.sh
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-07-03 21:26:07 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-07-03 21:26:07 +0000
commite1a2a0fdc08dc1deb019baf2fa98e1a133830e9a (patch)
treeac3dc3f90e2ee01c2f5cfa6dda25e673a6d1646b /bin/ebuild.sh
parent4e1c248d9b02b1ef04ac5207af2625130d45c45c (diff)
downloadportage-e1a2a0fdc08dc1deb019baf2fa98e1a133830e9a.tar.gz
portage-e1a2a0fdc08dc1deb019baf2fa98e1a133830e9a.tar.bz2
portage-e1a2a0fdc08dc1deb019baf2fa98e1a133830e9a.zip
Don't set RDEPEND=${RDEPEND-${DEPEND}} for EAPI=3 and simplify setting it for lower EAPIs.
svn path=/main/trunk/; revision=13768
Diffstat (limited to 'bin/ebuild.sh')
-rwxr-xr-xbin/ebuild.sh14
1 files changed, 4 insertions, 10 deletions
diff --git a/bin/ebuild.sh b/bin/ebuild.sh
index 32fa21c65..c032ae95e 100755
--- a/bin/ebuild.sh
+++ b/bin/ebuild.sh
@@ -1758,13 +1758,10 @@ _source_ebuild() {
rm "$PORTAGE_BUILDDIR/.ebuild_changed"
fi
- # This next line is not the same as export RDEPEND=${RDEPEND:-${DEPEND}}
- # That will test for unset *or* NULL (""). We want just to set for unset...
- # turn off glob expansion from here on in to prevent *'s and ? in the
- # DEPEND syntax from getting expanded :)
- set -f
- if [ "${RDEPEND-unset}" == "unset" ] ; then
- export RDEPEND=${DEPEND}
+ [[ -n $EAPI ]] || EAPI=0
+
+ if has "$EAPI" 0 1 2 ; then
+ export RDEPEND=${RDEPEND-${DEPEND}}
debug-print "RDEPEND: not set... Setting to: ${DEPEND}"
fi
@@ -1775,9 +1772,6 @@ _source_ebuild() {
PDEPEND="${PDEPEND} ${E_PDEPEND}"
unset ECLASS E_IUSE E_DEPEND E_RDEPEND E_PDEPEND
- set +f
-
- [[ -n $EAPI ]] || EAPI=0
# alphabetically ordered by $EBUILD_PHASE value
local f valid_phases