summaryrefslogtreecommitdiffstats
path: root/bin/ebuild.sh
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2009-04-08 19:37:25 +0000
committerZac Medico <zmedico@gentoo.org>2009-04-08 19:37:25 +0000
commit57c8de7fedde4b21ccada2586fb2dfcbc27cbd3c (patch)
treeb691c6a971d5e05c3f6478aee316cccdbaacce4a /bin/ebuild.sh
parent5d30d61010dccd27a89099d3fd1806b44c28ff20 (diff)
downloadportage-57c8de7fedde4b21ccada2586fb2dfcbc27cbd3c.tar.gz
portage-57c8de7fedde4b21ccada2586fb2dfcbc27cbd3c.tar.bz2
portage-57c8de7fedde4b21ccada2586fb2dfcbc27cbd3c.zip
Move the ebuild sourcing code into a new _source_ebuild() function.
svn path=/main/trunk/; revision=13299
Diffstat (limited to 'bin/ebuild.sh')
-rwxr-xr-xbin/ebuild.sh15
1 files changed, 9 insertions, 6 deletions
diff --git a/bin/ebuild.sh b/bin/ebuild.sh
index d1e2e8fd0..74a848a35 100755
--- a/bin/ebuild.sh
+++ b/bin/ebuild.sh
@@ -1802,11 +1802,7 @@ if ! hasq "$EBUILD_PHASE" clean cleanrm depend && \
unset PORTAGE_SANDBOX_ON
fi
-if ! hasq "$EBUILD_PHASE" clean cleanrm ; then
-if [[ $EBUILD_PHASE = depend || ! -f $T/environment || \
- -f $PORTAGE_BUILDDIR/.ebuild_changed ]] || \
- hasq noauto $FEATURES ; then
-
+_source_ebuild() {
# The bashrcs get an opportunity here to set aliases that will be expanded
# during sourcing of ebuilds and eclasses.
source_all_bashrcs
@@ -1845,7 +1841,14 @@ if [[ $EBUILD_PHASE = depend || ! -f $T/environment || \
# This needs to be exported since prepstrip is a separate shell script.
[[ -n $QA_PRESTRIPPED ]] && export QA_PRESTRIPPED
-fi
+}
+
+if ! hasq "$EBUILD_PHASE" clean cleanrm ; then
+ if [[ $EBUILD_PHASE = depend || ! -f $T/environment || \
+ -f $PORTAGE_BUILDDIR/.ebuild_changed ]] || \
+ hasq noauto $FEATURES ; then
+ _source_ebuild
+ fi
fi
# Set default EAPI if necessary, so that most