summaryrefslogtreecommitdiffstats
path: root/bin/misc-functions.sh
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2008-03-28 11:44:39 +0000
committerZac Medico <zmedico@gentoo.org>2008-03-28 11:44:39 +0000
commitb72320fe4e815f7818560d076138a95dda56a46d (patch)
treebe28d8120b64f83f2af71430261abaff5fc302d0 /bin/misc-functions.sh
parentf421c2dc35ed42593001fd5bdfd26d0ab0eeb4b5 (diff)
downloadportage-b72320fe4e815f7818560d076138a95dda56a46d.tar.gz
portage-b72320fe4e815f7818560d076138a95dda56a46d.tar.bz2
portage-b72320fe4e815f7818560d076138a95dda56a46d.zip
Bug #97776 - Tell rpmbuild to clean it's working files after completion.
(trunk r9428) svn path=/main/branches/2.1.2/; revision=9547
Diffstat (limited to 'bin/misc-functions.sh')
-rwxr-xr-xbin/misc-functions.sh2
1 files changed, 1 insertions, 1 deletions
diff --git a/bin/misc-functions.sh b/bin/misc-functions.sh
index 680c5b185..d38c9a14f 100755
--- a/bin/misc-functions.sh
+++ b/bin/misc-functions.sh
@@ -598,7 +598,7 @@ dyn_rpm() {
addwrite /usr/src/rpm
addwrite "${RPMDIR}"
dyn_spec
- rpmbuild -bb "${PF}.spec" || die "Failed to integrate rpm spec file"
+ rpmbuild -bb --clean --rmsource "${PF}.spec" || die "Failed to integrate rpm spec file"
install -D "/usr/src/rpm/RPMS/i386/${PN}-${PV}-${PR}.i386.rpm" \
"${RPMDIR}/${CATEGORY}/${PN}-${PV}-${PR}.rpm" || \
die "Failed to move rpm"