summaryrefslogtreecommitdiffstats
path: root/bin/misc-functions.sh
diff options
context:
space:
mode:
authorMarius Mauch <genone@gentoo.org>2008-03-03 22:17:43 +0000
committerMarius Mauch <genone@gentoo.org>2008-03-03 22:17:43 +0000
commitafa22002ed0fbc3c713d7fd81bdd838f60aaf2c5 (patch)
treeb0ae08d7e5f7c78aae4db0d5ca481ed38257b943 /bin/misc-functions.sh
parent9d4716cf4af66aa5db2481ee6b9f8a941a5175ba (diff)
downloadportage-afa22002ed0fbc3c713d7fd81bdd838f60aaf2c5.tar.gz
portage-afa22002ed0fbc3c713d7fd81bdd838f60aaf2c5.tar.bz2
portage-afa22002ed0fbc3c713d7fd81bdd838f60aaf2c5.zip
tell rpmbuild to clean it's working files after completion, bug #97776
svn path=/main/trunk/; revision=9428
Diffstat (limited to 'bin/misc-functions.sh')
-rwxr-xr-xbin/misc-functions.sh2
1 files changed, 1 insertions, 1 deletions
diff --git a/bin/misc-functions.sh b/bin/misc-functions.sh
index 3ccb7e7b0..6dbb75e09 100755
--- a/bin/misc-functions.sh
+++ b/bin/misc-functions.sh
@@ -623,7 +623,7 @@ dyn_rpm() {
addwrite /usr/src/rpm
addwrite "${RPMDIR}"
dyn_spec
- rpmbuild -bb "${PF}.spec" || die "Failed to integrate rpm spec file"
+ rpmbuild -bb --clean --rmsource "${PF}.spec" || die "Failed to integrate rpm spec file"
install -D "/usr/src/rpm/RPMS/i386/${PN}-${PV}-${PR}.i386.rpm" \
"${RPMDIR}/${CATEGORY}/${PN}-${PV}-${PR}.rpm" || \
die "Failed to move rpm"