summaryrefslogtreecommitdiffstats
path: root/bin/portageq
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2011-10-28 20:26:18 -0700
committerZac Medico <zmedico@gentoo.org>2011-10-28 20:26:18 -0700
commitc7a9678751251c027a3b2072962be49865c2c6f2 (patch)
tree06a5e941d3aa0d8511ba8703f4a72fe365cd8a81 /bin/portageq
parentb30bb192825fbc4f35225aa2334655b4ba7329f5 (diff)
downloadportage-c7a9678751251c027a3b2072962be49865c2c6f2.tar.gz
portage-c7a9678751251c027a3b2072962be49865c2c6f2.tar.bz2
portage-c7a9678751251c027a3b2072962be49865c2c6f2.zip
portageq: refer to <eroot> instead of <root>
Since commit a715b65f7bd36409c1283e6911265d1f4405ab7a, portageq takes EROOT as the first argument of commands that require a root argument. So, update the docs to refer to <eroot> instead of <root>.
Diffstat (limited to 'bin/portageq')
-rwxr-xr-xbin/portageq50
1 files changed, 25 insertions, 25 deletions
diff --git a/bin/portageq b/bin/portageq
index 66f6509d7..cee343fc8 100755
--- a/bin/portageq
+++ b/bin/portageq
@@ -79,7 +79,7 @@ def eval_atom_use(atom):
#
def has_version(argv):
- """<root> <category/package>
+ """<eroot> <category/package>
Return code 0 if it's available, 1 otherwise.
"""
if (len(argv) < 2):
@@ -126,7 +126,7 @@ has_version.uses_root = True
def best_version(argv):
- """<root> <category/package>
+ """<eroot> <category/package>
Returns category/package-version (without .ebuild).
"""
if (len(argv) < 2):
@@ -166,7 +166,7 @@ best_version.uses_root = True
def mass_best_version(argv):
- """<root> [<category/package>]+
+ """<eroot> [<category/package>]+
Returns category/package-version (without .ebuild).
"""
if (len(argv) < 2):
@@ -204,7 +204,7 @@ def metadata(argv):
sys.exit(1)
metadata.__doc__ = """
-<root> <pkgtype> <category/package> [<key>]+
+<eroot> <pkgtype> <category/package> [<key>]+
Returns metadata values for the specified package.
Available keys: %s
""" % ','.join(sorted(x for x in portage.auxdbkeys \
@@ -213,10 +213,10 @@ if not x.startswith('UNUSED_')))
metadata.uses_root = True
def contents(argv):
- """<root> <category/package>
+ """<eroot> <category/package>
List the files that are installed for a given package, with
one file listed on each line. All file names will begin with
- <root>.
+ <eroot>.
"""
if len(argv) != 2:
print("ERROR: expected 2 parameters, got %d!" % len(argv))
@@ -235,11 +235,11 @@ def contents(argv):
contents.uses_root = True
def owners(argv):
- """<root> [<filename>]+
+ """<eroot> [<filename>]+
Given a list of files, print the packages that own the files and which
files belong to each package. Files owned by a package are listed on
the lines below it, indented by a single tab character (\\t). All file
- paths must either start with <root> or be a basename alone.
+ paths must either start with <eroot> or be a basename alone.
Returns 1 if no owners could be found, and 0 otherwise.
"""
if len(argv) < 2:
@@ -272,7 +272,7 @@ def owners(argv):
f = os.path.join(cwd, f)
f = portage.normalize_path(f)
if not is_basename and not f.startswith(eroot):
- sys.stderr.write("ERROR: file paths must begin with <root>!\n")
+ sys.stderr.write("ERROR: file paths must begin with <eroot>!\n")
sys.stderr.flush()
return 2
if is_basename:
@@ -316,9 +316,9 @@ def owners(argv):
owners.uses_root = True
def is_protected(argv):
- """<root> <filename>
+ """<eroot> <filename>
Given a single filename, return code 0 if it's protected, 1 otherwise.
- The filename must begin with <root>.
+ The filename must begin with <eroot>.
"""
if len(argv) != 2:
sys.stderr.write("ERROR: expected 2 parameters, got %d!\n" % len(argv))
@@ -344,7 +344,7 @@ def is_protected(argv):
f = portage.normalize_path(f)
if not f.startswith(root):
- err.write("ERROR: file paths must begin with <root>!\n")
+ err.write("ERROR: file paths must begin with <eroot>!\n")
err.flush()
return 2
@@ -363,9 +363,9 @@ def is_protected(argv):
is_protected.uses_root = True
def filter_protected(argv):
- """<root>
+ """<eroot>
Read filenames from stdin and write them to stdout if they are protected.
- All filenames are delimited by \\n and must begin with <root>.
+ All filenames are delimited by \\n and must begin with <eroot>.
"""
if len(argv) != 1:
sys.stderr.write("ERROR: expected 1 parameter, got %d!\n" % len(argv))
@@ -405,7 +405,7 @@ def filter_protected(argv):
f = portage.normalize_path(f)
if not f.startswith(root):
- err.write("ERROR: file paths must begin with <root>!\n")
+ err.write("ERROR: file paths must begin with <eroot>!\n")
err.flush()
errors += 1
continue
@@ -423,7 +423,7 @@ def filter_protected(argv):
filter_protected.uses_root = True
def best_visible(argv):
- """<root> [pkgtype] <atom>
+ """<eroot> [pkgtype] <atom>
Returns category/package-version (without .ebuild).
The pkgtype argument defaults to "ebuild" if unspecified,
otherwise it must be one of ebuild, binary, or installed.
@@ -503,7 +503,7 @@ best_visible.uses_root = True
def mass_best_visible(argv):
- """<root> [<category/package>]+
+ """<eroot> [<category/package>]+
Returns category/package-version (without .ebuild).
"""
if (len(argv) < 2):
@@ -519,7 +519,7 @@ mass_best_visible.uses_root = True
def all_best_visible(argv):
- """<root>
+ """<eroot>
Returns all best_visible packages (without .ebuild).
"""
if len(argv) < 1:
@@ -536,7 +536,7 @@ all_best_visible.uses_root = True
def match(argv):
- """<root> <atom>
+ """<eroot> <atom>
Returns a \\n separated list of category/package-version.
When given an empty string, all installed packages will
be listed.
@@ -586,7 +586,7 @@ def match(argv):
match.uses_root = True
def expand_virtual(argv):
- """<root> <atom>
+ """<eroot> <atom>
Returns a \\n separated list of atoms expanded from a
given virtual atom (GLEP 37 virtuals only),
excluding blocker atoms. Satisfied
@@ -700,8 +700,8 @@ def envvar(argv):
print(portage.settings[arg])
def get_repos(argv):
- """<root>
- Returns all repos with names (repo_name file) argv[0] = $ROOT
+ """<eroot>
+ Returns all repos with names (repo_name file) argv[0] = $EROOT
"""
if len(argv) < 1:
print("ERROR: insufficient parameters!")
@@ -709,8 +709,8 @@ def get_repos(argv):
print(" ".join(portage.db[argv[0]]["porttree"].dbapi.getRepositories()))
def get_repo_path(argv):
- """<root> <repo_id>+
- Returns the path to the repo named argv[1], argv[0] = $ROOT
+ """<eroot> <repo_id>+
+ Returns the path to the repo named argv[1], argv[0] = $EROOT
"""
if len(argv) < 2:
print("ERROR: insufficient parameters!")
@@ -722,7 +722,7 @@ def get_repo_path(argv):
print(path)
def list_preserved_libs(argv):
- """<root>
+ """<eroot>
Print a list of libraries preserved during a package update in the form
package: path. Returns 1 if no preserved libraries could be found,
0 otherwise.