summaryrefslogtreecommitdiffstats
path: root/bin/repoman
diff options
context:
space:
mode:
authorAlec Warner <antarus@gentoo.org>2006-06-10 22:54:44 +0000
committerAlec Warner <antarus@gentoo.org>2006-06-10 22:54:44 +0000
commitc2db634dd974530aa67d557e93a94410bd888f2c (patch)
tree88f6ad93d2b39599a5bf3b3b9fe7e0fe06ba5352 /bin/repoman
parent5b3d19065df789e49ba197d5d883d4e3c5ca8726 (diff)
downloadportage-c2db634dd974530aa67d557e93a94410bd888f2c.tar.gz
portage-c2db634dd974530aa67d557e93a94410bd888f2c.tar.bz2
portage-c2db634dd974530aa67d557e93a94410bd888f2c.zip
Fix LIVEVCS.stable for -* keywords
svn path=/main/trunk/; revision=3487
Diffstat (limited to 'bin/repoman')
-rwxr-xr-xbin/repoman2
1 files changed, 1 insertions, 1 deletions
diff --git a/bin/repoman b/bin/repoman
index b6808d1f9..4125aa972 100755
--- a/bin/repoman
+++ b/bin/repoman
@@ -1020,7 +1020,7 @@ for x in scanlist:
not be allowed to be marked stable
"""
if set(["darcs","cvs","subversion","git"]).intersection(myaux["INHERITED"].split()):
- bad_stable_keywords = [keyword for keyword in myaux["KEYWORDS"].split() if not keyword.startswith("~")]
+ bad_stable_keywords = [keyword for keyword in myaux["KEYWORDS"].split() if not keyword.startswith("~") and not keyword.startswith("-")]
if bad_stable_keywords:
stats["LIVEVCS.stable"] += 1
fails["LIVEVCS.stable"].append(x+"/"+y+".ebuild with stable keywords:%s " % bad_stable_keywords)