summaryrefslogtreecommitdiffstats
path: root/bin/repoman
diff options
context:
space:
mode:
authorSimon Stelling <blubb@gentoo.org>2006-05-01 18:51:48 +0000
committerSimon Stelling <blubb@gentoo.org>2006-05-01 18:51:48 +0000
commitd0325c25afa83e66310108a0a0fe74926051a83d (patch)
treefc04419144d4e4a628a5ef8cb4769840b8dfe071 /bin/repoman
parentcf4a8d3da43c1f2bd5986bedcf22c76b1ad7fb9b (diff)
downloadportage-d0325c25afa83e66310108a0a0fe74926051a83d.tar.gz
portage-d0325c25afa83e66310108a0a0fe74926051a83d.tar.bz2
portage-d0325c25afa83e66310108a0a0fe74926051a83d.zip
revert my last commit except for the parts i really wanted to commit
svn path=/main/trunk/; revision=3295
Diffstat (limited to 'bin/repoman')
-rwxr-xr-xbin/repoman8
1 files changed, 4 insertions, 4 deletions
diff --git a/bin/repoman b/bin/repoman
index e91169f29..a6bbd8fa2 100755
--- a/bin/repoman
+++ b/bin/repoman
@@ -1074,10 +1074,10 @@ for x in scanlist:
badlicsyntax = badlicsyntax > 0
badprovsyntax = badprovsyntax > 0
-# if not baddepsyntax:
-# if x11_deprecation_check(" ".join([myaux["DEPEND"], myaux["RDEPEND"], myaux["PDEPEND"]])):
-# stats["usage.obsolete"] += 1
-# fails["usage.obsolete"].append("%s/%s.ebuild: not migrated to modular X" % (x, y))
+ if not baddepsyntax:
+ if x11_deprecation_check(" ".join([myaux["DEPEND"], myaux["RDEPEND"], myaux["PDEPEND"]])):
+ stats["usage.obsolete"] += 1
+ fails["usage.obsolete"].append("%s/%s.ebuild: not migrated to modular X" % (x, y))
for keyword,arch,groups in arches: