summaryrefslogtreecommitdiffstats
path: root/bin/repoman
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2008-03-28 12:59:23 +0000
committerZac Medico <zmedico@gentoo.org>2008-03-28 12:59:23 +0000
commit20e1130aea9e5ed261f9a3a7be40efdb1805559c (patch)
treedd0f74463e2f881e4c8a42fc6c255328aa610550 /bin/repoman
parent0ec342605b23f36aa6510087525889c2f6eb6588 (diff)
downloadportage-20e1130aea9e5ed261f9a3a7be40efdb1805559c.tar.gz
portage-20e1130aea9e5ed261f9a3a7be40efdb1805559c.tar.bz2
portage-20e1130aea9e5ed261f9a3a7be40efdb1805559c.zip
Bug #212509 - Display a note about the --without-mask option when there
are masked packages. (trunk r9521) svn path=/main/branches/2.1.2/; revision=9574
Diffstat (limited to 'bin/repoman')
-rwxr-xr-xbin/repoman6
1 files changed, 6 insertions, 0 deletions
diff --git a/bin/repoman b/bin/repoman
index 18f4d7267..f1cb3016e 100755
--- a/bin/repoman
+++ b/bin/repoman
@@ -1104,6 +1104,7 @@ if isCvs:
new_ebuilds.update(x for x in mynew if x.endswith(".ebuild"))
del mycvstree, mynew
+have_masked = False
dofail = 0
arch_caches={}
arch_xmatch_caches = {}
@@ -1834,6 +1835,7 @@ for x in scanlist:
ismasked = os.path.join(catdir, y) not in \
portdb.xmatch("list-visible", x)
if ismasked:
+ have_masked = True
if "--ignore-masked" in myoptions:
continue
#we are testing deps for a masked package; give it some lee-way
@@ -1958,6 +1960,10 @@ def grouplist(mylist,seperator="/"):
mygroups[xs[0]]+=[seperator.join(xs[1:])]
return mygroups
+if have_masked and not ("--without-mask" in myoptions or "--ignore-masked" in myoptions):
+ print bold("Note: use --without-mask to check " + \
+ "KEYWORDS on dependencies of masked packages")
+
if mymode!="commit":
if dofull:
print bold("Note: type \"repoman full\" for a complete listing.")