summaryrefslogtreecommitdiffstats
path: root/bin/repoman
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2007-12-21 03:29:58 +0000
committerZac Medico <zmedico@gentoo.org>2007-12-21 03:29:58 +0000
commit825b90d98cee593ffeaf57b4379bc64bf1dd8ec4 (patch)
treed5edafe23c8b35edc0aefbfe648fc7111dc16d4c /bin/repoman
parentdccc1676525d274cd4c8b8204825e0193860a5ba (diff)
downloadportage-825b90d98cee593ffeaf57b4379bc64bf1dd8ec4.tar.gz
portage-825b90d98cee593ffeaf57b4379bc64bf1dd8ec4.tar.bz2
portage-825b90d98cee593ffeaf57b4379bc64bf1dd8ec4.zip
Eliminate redundant "notadded" error filtering. (trunk r9023)
svn path=/main/branches/2.1.2/; revision=9024
Diffstat (limited to 'bin/repoman')
-rwxr-xr-xbin/repoman8
1 files changed, 1 insertions, 7 deletions
diff --git a/bin/repoman b/bin/repoman
index 2596b4b45..25d6a54be 100755
--- a/bin/repoman
+++ b/bin/repoman
@@ -485,9 +485,6 @@ def last():
for x in qacats:
if not stats[x]:
continue
- if "notadded" in x and not isCvs:
- stats[x] = 0
- continue
dowarn = 1
if x not in qawarnings:
dofail = 1
@@ -1375,7 +1372,7 @@ for x in scanlist:
if os.stat(checkdir+"/"+y+".ebuild")[0] & 0x0248:
stats["file.executable"] += 1
fails["file.executable"].append(x+"/"+y+".ebuild")
- if y not in eadded:
+ if isCvs and y not in eadded:
#ebuild not added to cvs
stats["ebuild.notadded"]=stats["ebuild.notadded"]+1
fails["ebuild.notadded"].append(x+"/"+y+".ebuild")
@@ -1870,9 +1867,6 @@ dofull = mymode not in ("full", "lfull")
for x in qacats:
if not stats[x]:
continue
- if "notadded" in x and not isCvs:
- stats[x] = 0
- continue
dowarn = 1
if x not in qawarnings:
dofail = 1