summaryrefslogtreecommitdiffstats
path: root/bin/repoman
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2008-03-28 13:07:05 +0000
committerZac Medico <zmedico@gentoo.org>2008-03-28 13:07:05 +0000
commitc5934a389dd13397baa88781bdc1221accb1ad26 (patch)
treef219a96034849af108ed7ec04e51a25edef77c2b /bin/repoman
parent8839a0f0bfb9b669d56b39c7ffb045046123075c (diff)
downloadportage-c5934a389dd13397baa88781bdc1221accb1ad26.tar.gz
portage-c5934a389dd13397baa88781bdc1221accb1ad26.tar.bz2
portage-c5934a389dd13397baa88781bdc1221accb1ad26.zip
Bug #213629 - Use EAPI.incompatible in cases where EAPI=0 and a default
IUSE is encountered. svn path=/main/branches/2.1.2/; revision=9577
Diffstat (limited to 'bin/repoman')
-rwxr-xr-xbin/repoman11
1 files changed, 9 insertions, 2 deletions
diff --git a/bin/repoman b/bin/repoman
index cc558d691..38de132ed 100755
--- a/bin/repoman
+++ b/bin/repoman
@@ -1679,8 +1679,15 @@ for x in scanlist:
for mypos in range(len(myuse)-1,-1,-1):
if myuse[mypos] and (myuse[mypos] in luselist[mykey]):
del myuse[mypos]
- if default_use and myaux["EAPI"] == "0":
- myuse += default_use
+
+ if default_use and eapi == "0":
+ for myflag in default_use:
+ stats['EAPI.incompatible'] += 1
+ fails['EAPI.incompatible'].append(
+ (relative_path + ": IUSE defaults" + \
+ " not supported with EAPI='%s':" + \
+ " '%s'") % (eapi, myflag))
+
for mypos in range(len(myuse)):
stats["IUSE.invalid"]=stats["IUSE.invalid"]+1
fails["IUSE.invalid"].append(x+"/"+y+".ebuild: %s" % myuse[mypos])