summaryrefslogtreecommitdiffstats
path: root/bin/repoman
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2007-09-06 17:52:39 +0000
committerZac Medico <zmedico@gentoo.org>2007-09-06 17:52:39 +0000
commitc9474026d9a1e8c13054d399ece669f23b14d54a (patch)
treee9286d301016de12bb30516eaea42f574b54dc64 /bin/repoman
parentbc8b37988283a5cd8ad5c2f5b82e598c57c532ba (diff)
downloadportage-c9474026d9a1e8c13054d399ece669f23b14d54a.tar.gz
portage-c9474026d9a1e8c13054d399ece669f23b14d54a.tar.bz2
portage-c9474026d9a1e8c13054d399ece669f23b14d54a.zip
Skip the most expensive QA tests when --force in enabled since there's no
point in wasting time on them when the user is intent on forcing the commit anyway. (trunk r7713) svn path=/main/branches/2.1.2/; revision=7741
Diffstat (limited to 'bin/repoman')
-rwxr-xr-xbin/repoman6
1 files changed, 6 insertions, 0 deletions
diff --git a/bin/repoman b/bin/repoman
index 4c98eb931..c7f60592c 100755
--- a/bin/repoman
+++ b/bin/repoman
@@ -1247,6 +1247,12 @@ for x in scanlist:
stats["usage.obsolete"] += 1
fails["usage.obsolete"].append("%s/%s.ebuild: not migrated to modular X" % (x, y))
+ if "--force" in myoptions:
+ # The dep_check() calls are the most expensive QA test. If --force
+ # is enabled, there's no point in wasting time on these since the
+ # user is intent on forcing the commit anyway.
+ continue
+
for keyword,arch,groups in arches:
if not profiles.has_key(arch):