summaryrefslogtreecommitdiffstats
path: root/bin/repoman
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2008-11-14 20:51:03 +0000
committerZac Medico <zmedico@gentoo.org>2008-11-14 20:51:03 +0000
commitd59d2bcd22f26ff8ca27216c42b1371cc3188ac5 (patch)
tree8e66934822a11895923a1e3900ac1578349f7beb /bin/repoman
parent57c4a04ed7ec806b2e5e29eb0c75d485fd1fc2ec (diff)
downloadportage-d59d2bcd22f26ff8ca27216c42b1371cc3188ac5.tar.gz
portage-d59d2bcd22f26ff8ca27216c42b1371cc3188ac5.tar.bz2
portage-d59d2bcd22f26ff8ca27216c42b1371cc3188ac5.zip
Exempt live ebuilds from KEYWORDS.missing and KEYWORDS.dropped warnings.
Thanks to Jorge Manuel B. S. Vicetto <jmbsvicetto@g.o> for the suggestion. (trunk r11911) svn path=/main/branches/2.1.6/; revision=11912
Diffstat (limited to 'bin/repoman')
-rwxr-xr-xbin/repoman7
1 files changed, 5 insertions, 2 deletions
diff --git a/bin/repoman b/bin/repoman
index 48a41385c..067707bce 100755
--- a/bin/repoman
+++ b/bin/repoman
@@ -1106,6 +1106,7 @@ for x in scanlist:
myaux = pkg.metadata
eapi = myaux["EAPI"]
inherited = pkg.inherited
+ live_ebuild = live_eclasses.intersection(inherited)
if not src_uri_error:
# Check that URIs don't reference a server from thirdpartymirrors.
@@ -1153,6 +1154,8 @@ for x in scanlist:
if catdir == "virtual" and \
missing_var in ("HOMEPAGE", "LICENSE"):
continue
+ if live_ebuild and missing_var == "KEYWORDS":
+ continue
myqakey=missingvars[pos]+".missing"
stats[myqakey]=stats[myqakey]+1
fails[myqakey].append(x+"/"+y+".ebuild")
@@ -1184,7 +1187,7 @@ for x in scanlist:
previous_keywords = slot_keywords.get(myaux["SLOT"])
if previous_keywords is None:
slot_keywords[myaux["SLOT"]] = set()
- else:
+ elif not live_ebuild:
dropped_keywords = previous_keywords.difference(ebuild_archs)
if dropped_keywords:
stats["KEYWORDS.dropped"] += 1
@@ -1210,7 +1213,7 @@ for x in scanlist:
Ebuilds that inherit a "Live" eclass (darcs,subversion,git,cvs,etc..) should
not be allowed to be marked stable
"""
- if live_eclasses.intersection(pkg.inherited):
+ if live_ebuild:
bad_stable_keywords = []
for keyword in keywords:
if not keyword.startswith("~") and \