summaryrefslogtreecommitdiffstats
path: root/bin/repoman
diff options
context:
space:
mode:
authorAlec Warner <antarus@gentoo.org>2006-04-07 00:48:59 +0000
committerAlec Warner <antarus@gentoo.org>2006-04-07 00:48:59 +0000
commita7972f2f756788f50e71bb2a9e985f77fd140c5b (patch)
tree46a547e32c85f7391ebe96739dc0b81a40590334 /bin/repoman
parent87010f8d058c843787587dac8d7404072e771ca0 (diff)
downloadportage-a7972f2f756788f50e71bb2a9e985f77fd140c5b.tar.gz
portage-a7972f2f756788f50e71bb2a9e985f77fd140c5b.tar.bz2
portage-a7972f2f756788f50e71bb2a9e985f77fd140c5b.zip
Change == None to is None
svn path=/main/trunk/; revision=3085
Diffstat (limited to 'bin/repoman')
-rwxr-xr-xbin/repoman6
1 files changed, 3 insertions, 3 deletions
diff --git a/bin/repoman b/bin/repoman
index 123b5672d..4a46196a5 100755
--- a/bin/repoman
+++ b/bin/repoman
@@ -347,7 +347,7 @@ if len(sys.argv)>1:
elif sys.argv[x] in repoman_shortoptions.keys():
sys.argv[x] = repoman_shortoptions[sys.argv[x]]
if sys.argv[x] in modes:
- if mymode==None:
+ if mymode is None:
mymode=sys.argv[x]
else:
err("Please specify either \""+mymode+"\" or \""+sys.argv[x]+"\", but not both.")
@@ -368,7 +368,7 @@ if len(sys.argv)>1:
else:
err_help("\""+sys.argv[x]+"\" is not a valid mode or option.")
x=x+1
-if mymode==None:
+if mymode is None:
mymode="scan"
if mymode=="help" or ("--help" in myoptions):
help(exitstatus=0)
@@ -942,7 +942,7 @@ for x in scanlist:
stats["digest.missing"]=stats["digest.missing"]+1
fails["digest.missing"].append(x+"/files/digest-"+y)
myesplit=portage.pkgsplit(y)
- if myesplit==None or not valid_ebuild_name(x.split("/")[0]+"/"+y):
+ if myesplit is None or not valid_ebuild_name(x.split("/")[0]+"/"+y):
stats["ebuild.invalidname"]=stats["ebuild.invalidname"]+1
fails["ebuild.invalidname"].append(x+"/"+y+".ebuild")
continue