summaryrefslogtreecommitdiffstats
path: root/bin/repoman
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2010-03-12 20:52:58 +0000
committerZac Medico <zmedico@gentoo.org>2010-03-12 20:52:58 +0000
commit6b035d05c64fd8a74d96484118bbe3e8006fa06c (patch)
tree122ea729da7def34d5683fa508e8a262d8fc280f /bin/repoman
parent396a20c52cca3ac5d107709ea442918866f10f57 (diff)
downloadportage-6b035d05c64fd8a74d96484118bbe3e8006fa06c.tar.gz
portage-6b035d05c64fd8a74d96484118bbe3e8006fa06c.tar.bz2
portage-6b035d05c64fd8a74d96484118bbe3e8006fa06c.zip
Simplyfy the virtual.exists check, and avoid deprecation warning triggered
by cpv_getkey called on an empty string. svn path=/main/trunk/; revision=15822
Diffstat (limited to 'bin/repoman')
-rwxr-xr-xbin/repoman4
1 files changed, 1 insertions, 3 deletions
diff --git a/bin/repoman b/bin/repoman
index f9fdc7408..a6ae9a08f 100755
--- a/bin/repoman
+++ b/bin/repoman
@@ -1419,9 +1419,7 @@ for x in scanlist:
if prov_cp != myprovide:
stats["virtual.versioned"]+=1
fails["virtual.versioned"].append(x+"/"+y+".ebuild: "+myprovide)
- prov_pkg = portage.cpv_getkey(
- portage.best(portdb.xmatch("match-all", prov_cp)))
- if prov_cp == prov_pkg:
+ if portdb.cp_list(prov_cp):
stats["virtual.exists"]+=1
fails["virtual.exists"].append(x+"/"+y+".ebuild: "+prov_cp)