summaryrefslogtreecommitdiffstats
path: root/bin/repoman
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2010-08-26 11:56:06 -0700
committerZac Medico <zmedico@gentoo.org>2010-08-26 11:56:06 -0700
commitc2801291b5f7f37847390fabdd8d8c0c2b6c8899 (patch)
tree383753f62f9da3978d08595097c8108b3cc94f69 /bin/repoman
parent944c1d7a84f8d27781dd7769ba0b324fbd4d3290 (diff)
downloadportage-c2801291b5f7f37847390fabdd8d8c0c2b6c8899.tar.gz
portage-c2801291b5f7f37847390fabdd8d8c0c2b6c8899.tar.bz2
portage-c2801291b5f7f37847390fabdd8d8c0c2b6c8899.zip
Fix repoman's allvalid variable to account for more possibly invalid
ebuilds.
Diffstat (limited to 'bin/repoman')
-rwxr-xr-xbin/repoman5
1 files changed, 4 insertions, 1 deletions
diff --git a/bin/repoman b/bin/repoman
index 0c0e7d0ed..1ad5b28b2 100755
--- a/bin/repoman
+++ b/bin/repoman
@@ -1095,6 +1095,7 @@ for x in scanlist:
checkdirlist=os.listdir(checkdir)
ebuildlist=[]
pkgs = {}
+ allvalid = True
for y in checkdirlist:
if (y in no_exec or y.endswith(".ebuild")) and \
stat.S_IMODE(os.stat(os.path.join(checkdir, y)).st_mode) & 0o111:
@@ -1107,14 +1108,17 @@ for x in scanlist:
try:
myaux = dict(zip(allvars, portdb.aux_get(cpv, allvars)))
except KeyError:
+ allvalid = False
stats["ebuild.syntax"] += 1
fails["ebuild.syntax"].append(os.path.join(x, y))
continue
except IOError:
+ allvalid = False
stats["ebuild.output"] += 1
fails["ebuild.output"].append(os.path.join(x, y))
continue
if not portage.eapi_is_supported(myaux["EAPI"]):
+ allvalid = False
stats["EAPI.unsupported"] += 1
fails["EAPI.unsupported"].append(os.path.join(x, y))
continue
@@ -1392,7 +1396,6 @@ for x in scanlist:
changelog_path = os.path.join(checkdir_relative, "ChangeLog")
changelog_modified = changelog_path in modified_changelogs
- allvalid = True
allmasked = True
# detect unused local USE-descriptions
used_useflags = set()