summaryrefslogtreecommitdiffstats
path: root/bin/repoman
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2008-06-30 21:54:20 +0000
committerZac Medico <zmedico@gentoo.org>2008-06-30 21:54:20 +0000
commitf69c3b0865cb6e7433644681663e15c0b18f89f0 (patch)
tree8aa912b0d5da4307849698a4c6c812190a0ec593 /bin/repoman
parent811906497dc7f81f835c30cb4b95bff398d65869 (diff)
downloadportage-f69c3b0865cb6e7433644681663e15c0b18f89f0.tar.gz
portage-f69c3b0865cb6e7433644681663e15c0b18f89f0.tar.bz2
portage-f69c3b0865cb6e7433644681663e15c0b18f89f0.zip
Bug #230245 - Use os.path.basename() on paths returned from `svn list`
and `svn status`. svn path=/main/trunk/; revision=10859
Diffstat (limited to 'bin/repoman')
-rwxr-xr-xbin/repoman4
1 files changed, 2 insertions, 2 deletions
diff --git a/bin/repoman b/bin/repoman
index 55a8a301f..b0c44ddb1 100755
--- a/bin/repoman
+++ b/bin/repoman
@@ -889,7 +889,7 @@ for x in scanlist:
if l[-1:] == "/":
continue
if l[-7:] == ".ebuild":
- eadded.append(l[:-7])
+ eadded.append(os.path.basename(l[:-7]))
if vcs == "svn":
myf = os.popen("svn status " + checkdir)
myl=myf.readlines()
@@ -898,7 +898,7 @@ for x in scanlist:
if l[0] == "A":
l = l.rstrip().split(' ')[-1]
if l[-7:] == ".ebuild":
- eadded.append(l[:-7])
+ eadded.append(os.path.basename(l[:-7]))
except IOError:
if options.mode == 'commit' and vcs == "cvs":
stats["CVS/Entries.IO_error"] += 1