summaryrefslogtreecommitdiffstats
path: root/bin/repoman
diff options
context:
space:
mode:
authorMichał Górny <gentoo@mgorny.alt.pl>2010-07-14 23:17:07 +0200
committerZac Medico <zmedico@gentoo.org>2010-07-14 19:34:58 -0700
commit3fdb3a7a3fa3e057ba2bb898826647191dbeb075 (patch)
tree660d34fa1cb46e2c14a20988af33eedb0b8b2f27 /bin/repoman
parent3ae4b531529a117d6adf4516e258fa1ac8508569 (diff)
downloadportage-3fdb3a7a3fa3e057ba2bb898826647191dbeb075.tar.gz
portage-3fdb3a7a3fa3e057ba2bb898826647191dbeb075.tar.bz2
portage-3fdb3a7a3fa3e057ba2bb898826647191dbeb075.zip
Combine the two 'file.executable' checks into a single one.
Instead of performing a single 'file.executable' check on auxiliary files and then another one on ebuild files, use a single check for them. This unifies the path output too.
Diffstat (limited to 'bin/repoman')
-rwxr-xr-xbin/repoman5
1 files changed, 1 insertions, 4 deletions
diff --git a/bin/repoman b/bin/repoman
index 8834b642b..0a1a92dd8 100755
--- a/bin/repoman
+++ b/bin/repoman
@@ -1078,7 +1078,7 @@ for x in scanlist:
ebuildlist=[]
pkgs = {}
for y in checkdirlist:
- if y in no_exec and \
+ if (y in no_exec or y.endswith(".ebuild")) and \
stat.S_IMODE(os.stat(os.path.join(checkdir, y)).st_mode) & 0o111:
stats["file.executable"] += 1
fails["file.executable"].append(os.path.join(checkdir, y))
@@ -1394,9 +1394,6 @@ for x in scanlist:
stats['changelog.ebuildadded'] += 1
fails['changelog.ebuildadded'].append(relative_path)
- if stat.S_IMODE(os.stat(full_path).st_mode) & 0o111:
- stats["file.executable"] += 1
- fails["file.executable"].append(x+"/"+y+".ebuild")
if vcs in ("cvs", "svn", "bzr") and check_ebuild_notadded and y not in eadded:
#ebuild not added to vcs
stats["ebuild.notadded"]=stats["ebuild.notadded"]+1