summaryrefslogtreecommitdiffstats
path: root/bin
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2012-04-30 19:26:52 -0700
committerZac Medico <zmedico@gentoo.org>2012-04-30 19:30:10 -0700
commitaa63202838c5346692b49ae26fff16b6977fb56c (patch)
treeb2383fbf9eab6cd27c3de9d53ac49b585a0095e0 /bin
parent39a26141b40486108be9d147a228708da797a0e4 (diff)
downloadportage-aa63202838c5346692b49ae26fff16b6977fb56c.tar.gz
portage-aa63202838c5346692b49ae26fff16b6977fb56c.tar.bz2
portage-aa63202838c5346692b49ae26fff16b6977fb56c.zip
repoman: ignore false Service desktop entry error
This will fix bug #414125.
Diffstat (limited to 'bin')
-rwxr-xr-xbin/repoman8
1 files changed, 4 insertions, 4 deletions
diff --git a/bin/repoman b/bin/repoman
index 0163f8d30..1cdfcf674 100755
--- a/bin/repoman
+++ b/bin/repoman
@@ -76,6 +76,7 @@ from portage.output import bold, create_color_func, \
green, nocolor, red
from portage.output import ConsoleStyleFile, StyleWriter
from portage.util import cmp_sort_key, writemsg_level
+from portage.util._desktop_entry import validate_desktop_entry
from portage.package.ebuild.digestgen import digestgen
from portage.eapi import eapi_has_iuse_defaults, eapi_has_required_use
@@ -1565,15 +1566,14 @@ for x in effective_scanlist:
(checkdir, y, m.group(0)))
if desktop_file_validate and desktop_pattern.match(y):
- status, cmd_output = subprocess_getstatusoutput(
- "'%s' '%s'" % (desktop_file_validate, full_path))
- if os.WIFEXITED(status) and os.WEXITSTATUS(status) != os.EX_OK:
+ cmd_output = validate_desktop_entry(full_path)
+ if cmd_output:
# Note: in the future we may want to grab the
# warnings in addition to the errors. We're
# just doing errors now since we don't want
# to generate too much noise at first.
error_re = re.compile(r'.*\s*error:\s*(.*)')
- for line in cmd_output.splitlines():
+ for line in cmd_output:
error_match = error_re.match(line)
if error_match is None:
continue