summaryrefslogtreecommitdiffstats
path: root/bin
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2012-05-05 18:00:57 +0200
committerArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2012-05-05 18:00:57 +0200
commite3d3ff4f22f5e41f12b2518d23ebea354a006b7b (patch)
treebef99883ff87313f975ebed8d558cadd6470965b /bin
parent72314d2e24aa96af614b052b8b29e6d02d37a641 (diff)
downloadportage-e3d3ff4f22f5e41f12b2518d23ebea354a006b7b.tar.gz
portage-e3d3ff4f22f5e41f12b2518d23ebea354a006b7b.tar.bz2
portage-e3d3ff4f22f5e41f12b2518d23ebea354a006b7b.zip
Enable globstar shell option by default in EAPI="4-python".
Diffstat (limited to 'bin')
-rwxr-xr-xbin/ebuild.sh4
1 files changed, 4 insertions, 0 deletions
diff --git a/bin/ebuild.sh b/bin/ebuild.sh
index 173865cde..32dc64f0c 100755
--- a/bin/ebuild.sh
+++ b/bin/ebuild.sh
@@ -512,6 +512,10 @@ if ! has "$EBUILD_PHASE" clean cleanrm depend && \
[[ -n $EAPI ]] || EAPI=0
fi
+if has "${EAPI:-0}" 4-python; then
+ shopt -s globstar
+fi
+
if ! has "$EBUILD_PHASE" clean cleanrm ; then
if [[ $EBUILD_PHASE = depend || ! -f $T/environment || \
-f $PORTAGE_BUILDDIR/.ebuild_changed ]] || \