summaryrefslogtreecommitdiffstats
path: root/bin
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2007-09-06 17:08:51 +0000
committerZac Medico <zmedico@gentoo.org>2007-09-06 17:08:51 +0000
commitd4bbd3e2a079e9577fadacbb67ce312b2b3e2a1f (patch)
treea5678aa75a437a18e5b680c477b529488f29640f /bin
parentc13a95e49aecd350ac7e389500b192ccd7c9007f (diff)
downloadportage-d4bbd3e2a079e9577fadacbb67ce312b2b3e2a1f.tar.gz
portage-d4bbd3e2a079e9577fadacbb67ce312b2b3e2a1f.tar.bz2
portage-d4bbd3e2a079e9577fadacbb67ce312b2b3e2a1f.zip
Bug #190214 - Make the rpm phase use /usr/src/rpm instead of /usr/src/redhat.
Bug #190144 - Use the realpath of DISTDIR so that things like subversion.eclass are compatible with sandbox. (trunk r7700) svn path=/main/branches/2.1.2/; revision=7732
Diffstat (limited to 'bin')
-rwxr-xr-xbin/misc-functions.sh12
1 files changed, 8 insertions, 4 deletions
diff --git a/bin/misc-functions.sh b/bin/misc-functions.sh
index 55802daad..eecf21855 100755
--- a/bin/misc-functions.sh
+++ b/bin/misc-functions.sh
@@ -517,7 +517,9 @@ dyn_package() {
}
dyn_spec() {
- tar czf "/usr/src/redhat/SOURCES/${PF}.tar.gz" "${O}/${PF}.ebuild" "${O}/files" || die "Failed to create base rpm tarball."
+ tar czf "/usr/src/rpm/SOURCES/${PF}.tar.gz" \
+ "${O}/${PF}.ebuild" "${O}/files" || \
+ die "Failed to create base rpm tarball."
cat <<__END1__ > ${PF}.spec
Summary: ${DESCRIPTION}
@@ -549,11 +551,13 @@ __END1__
}
dyn_rpm() {
- addwrite /usr/src/redhat/
- addwrite ${RPMDIR}
+ addwrite /usr/src/rpm
+ addwrite "${RPMDIR}"
dyn_spec
rpmbuild -bb "${PF}.spec" || die "Failed to integrate rpm spec file"
- install -D "/usr/src/redhat/RPMS/i386/${PN}-${PV}-${PR}.i386.rpm" "${RPMDIR}/${CATEGORY}/${PN}-${PV}-${PR}.rpm" || die "Failed to move rpm"
+ install -D "/usr/src/rpm/RPMS/i386/${PN}-${PV}-${PR}.i386.rpm" \
+ "${RPMDIR}/${CATEGORY}/${PN}-${PV}-${PR}.rpm" || \
+ die "Failed to move rpm"
}
if [ -n "${MISC_FUNCTIONS_ARGS}" ]; then