summaryrefslogtreecommitdiffstats
path: root/bin
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2010-10-05 20:43:39 +0200
committerZac Medico <zmedico@gentoo.org>2010-10-27 07:35:55 -0700
commit078683fff6db94b159f7fda2b1eccf0f0d8f8880 (patch)
tree025c503ede52d9021a3d8dde5d86bd8a0387106a /bin
parent0f16c786181e9cc963669496b9dc9d448ad552b1 (diff)
downloadportage-078683fff6db94b159f7fda2b1eccf0f0d8f8880.tar.gz
portage-078683fff6db94b159f7fda2b1eccf0f0d8f8880.tar.bz2
portage-078683fff6db94b159f7fda2b1eccf0f0d8f8880.zip
egencache --update-changelogs: reverse the sort order for headers.
Diffstat (limited to 'bin')
-rwxr-xr-xbin/egencache5
1 files changed, 3 insertions, 2 deletions
diff --git a/bin/egencache b/bin/egencache
index 783cfc428..e0834a4ad 100755
--- a/bin/egencache
+++ b/bin/egencache
@@ -623,7 +623,8 @@ class GenChangeLogs(object):
changed = [str(x) for x in sorted(changed)]
wroteheader = False
- for c in changed:
+ # Reverse the sort order for headers.
+ for c in reversed(changed):
if c.startswith('+') and c.endswith('.ebuild'):
output.write('*%s (%s)\n' % (c[1:-7], date))
wroteheader = True
@@ -654,7 +655,7 @@ class GenChangeLogs(object):
output.write('\n%s\n\n' % '\n'.join([self._wrapper.fill(x) for x in body]))
output.close()
-
+
def run(self):
repo_path = self._portdb.porttrees[0]
os.chdir(repo_path)