summaryrefslogtreecommitdiffstats
path: root/bin
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2007-01-28 22:10:08 +0000
committerZac Medico <zmedico@gentoo.org>2007-01-28 22:10:08 +0000
commitd2b890bd735aceac8b098596162545e6e12bbfca (patch)
tree372cbf9efc1bab3a149cccaaeeb75a9cf30fe69d /bin
parentf8dee739dae3a33124405643ebcb3c32cbb9f833 (diff)
downloadportage-d2b890bd735aceac8b098596162545e6e12bbfca.tar.gz
portage-d2b890bd735aceac8b098596162545e6e12bbfca.tar.bz2
portage-d2b890bd735aceac8b098596162545e6e12bbfca.zip
Minor cleanup for the LIVEVCS.stable code.
svn path=/main/trunk/; revision=5821
Diffstat (limited to 'bin')
-rwxr-xr-xbin/repoman16
1 files changed, 12 insertions, 4 deletions
diff --git a/bin/repoman b/bin/repoman
index 695141ca1..09a340f4e 100755
--- a/bin/repoman
+++ b/bin/repoman
@@ -1042,12 +1042,20 @@ for x in scanlist:
Ebuilds that inherit a "Live" eclasss (darcs,subversion,git,cvs,etc..) should
not be allowed to be marked stable
"""
- if set(["darcs","cvs","subversion","git"]).intersection(myaux["INHERITED"].split()):
- bad_stable_keywords = [keyword for keyword in myaux["KEYWORDS"].split() if not keyword.startswith("~") and not keyword.startswith("-")]
+ if set(["darcs","cvs","subversion","git"]).intersection(
+ myaux["INHERITED"].split()):
+ bad_stable_keywords = []
+ for keyword in myaux["KEYWORDS"].split():
+ if not keyword.startswith("~") and \
+ not keyword.startswith("-"):
+ bad_stable_keywords.append(keyword)
+ del keyword
if bad_stable_keywords:
stats["LIVEVCS.stable"] += 1
- fails["LIVEVCS.stable"].append(x+"/"+y+".ebuild with stable keywords:%s " % bad_stable_keywords)
- del bad_stable_keywords
+ fails["LIVEVCS.stable"].append(
+ x + "/" + y + ".ebuild with stable keywords:%s " % \
+ bad_stable_keywords)
+ del bad_stable_keywords
if "--ignore-arches" in myoptions:
arches = [[repoman_settings["ARCH"], repoman_settings["ARCH"],