summaryrefslogtreecommitdiffstats
path: root/bin
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2008-08-07 00:32:19 +0000
committerZac Medico <zmedico@gentoo.org>2008-08-07 00:32:19 +0000
commitc054a61d345bc8db38c4aea596e9ae12ec1f4643 (patch)
tree7c7c7d124592571d6811a416f5599853e62c9106 /bin
parent2caf6ce78f85a21581bf9ee043ef93c3df89fbf7 (diff)
downloadportage-c054a61d345bc8db38c4aea596e9ae12ec1f4643.tar.gz
portage-c054a61d345bc8db38c4aea596e9ae12ec1f4643.tar.bz2
portage-c054a61d345bc8db38c4aea596e9ae12ec1f4643.zip
Replace call to `svn list` with a call to `svn status --depth=files --verbose`
since the former contacts the server while the latter does not. Thanks to Arfrever for this patch. svn path=/main/trunk/; revision=11339
Diffstat (limited to 'bin')
-rwxr-xr-xbin/repoman12
1 files changed, 6 insertions, 6 deletions
diff --git a/bin/repoman b/bin/repoman
index f892487e9..26a669d34 100755
--- a/bin/repoman
+++ b/bin/repoman
@@ -758,8 +758,8 @@ arch_xmatch_caches = {}
shared_xmatch_caches = {"cp-list":{}}
# Disable the "ebuild.notadded" check when not in commit mode and
-# running `svn list` and `svn status` calls in every package dir
-# will be too expensive.
+# running `svn status` in every package dir will be too expensive.
+
check_ebuild_notadded = not \
(vcs == "svn" and repolevel < 3 and options.mode != "commit")
@@ -862,8 +862,8 @@ for x in scanlist:
if vcs == "cvs":
myf=open(checkdir+"/CVS/Entries","r")
if vcs == "svn":
- myf = os.popen("svn list " + checkdir)
- myl=myf.readlines()
+ myf = os.popen("svn status --depth=files --verbose " + checkdir)
+ myl = myf.readlines()
myf.close()
for l in myl:
if vcs == "cvs":
@@ -875,9 +875,9 @@ for x in scanlist:
if splitl[0][-7:]==".ebuild":
eadded.append(splitl[0][:-7])
if vcs == "svn":
- l = l.rstrip();
- if l[-1:] == "/":
+ if l[:1] == "?":
continue
+ l = l.split()[-1]
if l[-7:] == ".ebuild":
eadded.append(os.path.basename(l[:-7]))
if vcs == "svn":