summaryrefslogtreecommitdiffstats
path: root/bin
diff options
context:
space:
mode:
authorAlec Warner <antarus@gentoo.org>2008-01-05 20:31:31 +0000
committerAlec Warner <antarus@gentoo.org>2008-01-05 20:31:31 +0000
commitf538e6a6358052fae47fa999f7ffe711a63cc678 (patch)
treee35e9dd140e18e69f1e941bf11a268bd6b2c30e1 /bin
parentb36c8955cedf9e01869efe8400c1ed98ab21ec98 (diff)
downloadportage-f538e6a6358052fae47fa999f7ffe711a63cc678.tar.gz
portage-f538e6a6358052fae47fa999f7ffe711a63cc678.tar.bz2
portage-f538e6a6358052fae47fa999f7ffe711a63cc678.zip
per bug 204468, remove old check from repoman (all ebuilds in gentoo-x86 are migrated).
svn path=/main/trunk/; revision=9144
Diffstat (limited to 'bin')
-rwxr-xr-xbin/repoman26
1 files changed, 0 insertions, 26 deletions
diff --git a/bin/repoman b/bin/repoman
index c4453f992..ebeaea915 100755
--- a/bin/repoman
+++ b/bin/repoman
@@ -861,27 +861,6 @@ else:
#this can be problematic if xmllint changes their output
xmllint_capable=True
-
-def x11_deprecation_check(depstr):
- if depstr.find("virtual/x11") == -1:
- return False
- depsplit = depstr.split()
- ok_stack = []
- ok = False
- for token in depsplit:
- if token == "(":
- ok_stack.append(ok)
- ok = False
- elif token == ")":
- ok = ok_stack.pop()
- elif token == "||":
- ok = True
- else:
- ok = False
- if token.find("virtual/x11") != -1 and (not ok_stack or not ok_stack[-1]):
- return True
- return False
-
if options.mode == 'commit':
retval = ("","")
if isCvs:
@@ -1443,11 +1422,6 @@ for x in scanlist:
badlicsyntax = badlicsyntax > 0
badprovsyntax = badprovsyntax > 0
- if not baddepsyntax:
- if x11_deprecation_check(" ".join([myaux["DEPEND"], myaux["RDEPEND"], myaux["PDEPEND"]])):
- stats["usage.obsolete"] += 1
- fails["usage.obsolete"].append("%s/%s.ebuild: not migrated to modular X" % (x, y))
-
# uselist checks - global
myuse = []
default_use = []