summaryrefslogtreecommitdiffstats
path: root/pym/_emerge/EbuildPhase.py
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2010-03-02 20:59:00 +0000
committerZac Medico <zmedico@gentoo.org>2010-03-02 20:59:00 +0000
commit04420a58490d17ab9c8505710f8c359e03c1c12e (patch)
tree39dd0ee782149cd0439df27605f097241a4cb27a /pym/_emerge/EbuildPhase.py
parent4ca82bc8040ba7a3f30e26204a9f38fe75ea45e4 (diff)
downloadportage-04420a58490d17ab9c8505710f8c359e03c1c12e.tar.gz
portage-04420a58490d17ab9c8505710f8c359e03c1c12e.tar.bz2
portage-04420a58490d17ab9c8505710f8c359e03c1c12e.zip
Split doebuild and related code to the portage.package.ebuild module.
(trunk r15448) svn path=/main/branches/2.1.7/; revision=15657
Diffstat (limited to 'pym/_emerge/EbuildPhase.py')
-rw-r--r--pym/_emerge/EbuildPhase.py13
1 files changed, 7 insertions, 6 deletions
diff --git a/pym/_emerge/EbuildPhase.py b/pym/_emerge/EbuildPhase.py
index 89bdb078f..81b0e1f8d 100644
--- a/pym/_emerge/EbuildPhase.py
+++ b/pym/_emerge/EbuildPhase.py
@@ -5,6 +5,9 @@
from _emerge.MiscFunctionsProcess import MiscFunctionsProcess
from _emerge.EbuildProcess import EbuildProcess
from _emerge.CompositeTask import CompositeTask
+from portage.package.ebuild.doebuild import _check_build_log, \
+ _post_phase_cmds, _post_src_install_chost_fix, \
+ _post_src_install_uid_fix
from portage.util import writemsg, writemsg_stdout
import portage
from portage import os
@@ -18,8 +21,6 @@ class EbuildPhase(CompositeTask):
__slots__ = ("background", "pkg", "phase",
"scheduler", "settings", "tree")
- _post_phase_cmds = portage._post_phase_cmds
-
def _start(self):
ebuild_process = EbuildProcess(background=self.background,
@@ -39,7 +40,7 @@ class EbuildPhase(CompositeTask):
encoding=_encodings['fs'], errors='strict'),
mode='a', encoding=_encodings['content'], errors='replace')
try:
- portage._check_build_log(self.settings, out=out)
+ _check_build_log(self.settings, out=out)
msg = _unicode_decode(out.getvalue(),
encoding=_encodings['content'], errors='replace')
if msg:
@@ -66,12 +67,12 @@ class EbuildPhase(CompositeTask):
encoding=_encodings['fs'], errors='strict'),
mode='a', encoding=_encodings['content'], errors='replace')
out = log_file
- portage._post_src_install_chost_fix(settings)
- portage._post_src_install_uid_fix(settings, out=out)
+ _post_src_install_chost_fix(settings)
+ _post_src_install_uid_fix(settings, out=out)
if log_file is not None:
log_file.close()
- post_phase_cmds = self._post_phase_cmds.get(self.phase)
+ post_phase_cmds = _post_phase_cmds.get(self.phase)
if post_phase_cmds is not None:
post_phase = MiscFunctionsProcess(background=self.background,
commands=post_phase_cmds, phase=self.phase, pkg=self.pkg,