summaryrefslogtreecommitdiffstats
path: root/pym/_emerge/EbuildPhase.py
diff options
context:
space:
mode:
authorDavid James <davidjames@google.com>2011-04-28 14:22:15 -0700
committerZac Medico <zmedico@gentoo.org>2011-04-28 14:22:15 -0700
commitf86b547f1dbedb504de26e69ad66338258411a8f (patch)
tree04788238e50d32187c62d3c2e5d4c65a19da67e9 /pym/_emerge/EbuildPhase.py
parent593b57110c6f441d03d9ae623de9ff99a2e57905 (diff)
downloadportage-f86b547f1dbedb504de26e69ad66338258411a8f.tar.gz
portage-f86b547f1dbedb504de26e69ad66338258411a8f.tar.bz2
portage-f86b547f1dbedb504de26e69ad66338258411a8f.zip
Move preinst/postinst_bsdflags from bash to py
Moving these commands from shell to Python helps avoid an unnecessary call to misc-functions.sh for the postinst_bsdflags. This improves performance. BUG=none TEST=Run emerge-x86-generic -eg --jobs=16 libchrome Change-Id: I0c2af50b4d2f7644cabac84fde7fe4d682010c69 Review URL: http://codereview.chromium.org/6676107
Diffstat (limited to 'pym/_emerge/EbuildPhase.py')
-rw-r--r--pym/_emerge/EbuildPhase.py7
1 files changed, 6 insertions, 1 deletions
diff --git a/pym/_emerge/EbuildPhase.py b/pym/_emerge/EbuildPhase.py
index c9d17474e..07fb69ca7 100644
--- a/pym/_emerge/EbuildPhase.py
+++ b/pym/_emerge/EbuildPhase.py
@@ -17,7 +17,8 @@ portage.proxy.lazyimport.lazyimport(globals(),
'portage.package.ebuild.doebuild:_check_build_log,' + \
'_post_phase_cmds,_post_phase_userpriv_perms,' + \
'_post_src_install_chost_fix,' + \
- '_post_src_install_uid_fix'
+ '_post_src_install_uid_fix,_postinst_bsdflags,' + \
+ '_preinst_bsdflags'
)
from portage import os
from portage import StringIO
@@ -178,6 +179,10 @@ class EbuildPhase(CompositeTask):
encoding=_encodings['content'], errors='replace')
if msg:
self.scheduler.output(msg, log_path=logfile)
+ elif self.phase == "preinst":
+ _preinst_bsdflags(settings)
+ elif self.phase == "postinst":
+ _postinst_bsdflags(settings)
post_phase_cmds = _post_phase_cmds.get(self.phase)
if post_phase_cmds is not None: