summaryrefslogtreecommitdiffstats
path: root/pym/_emerge/actions.py
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2012-10-16 16:15:46 -0700
committerZac Medico <zmedico@gentoo.org>2012-10-16 16:15:46 -0700
commit43f3b93d4841ce638e73586a8d7b212f86f0c173 (patch)
tree064296d9711b1fa53b0df590a5483d23633964a0 /pym/_emerge/actions.py
parent687000cd2512155bde70d71df65ba9b88673ae4b (diff)
downloadportage-43f3b93d4841ce638e73586a8d7b212f86f0c173.tar.gz
portage-43f3b93d4841ce638e73586a8d7b212f86f0c173.tar.bz2
portage-43f3b93d4841ce638e73586a8d7b212f86f0c173.zip
emerge: optimize --moo, remove deprecated moo
The --moo action is fast like --help now. The "moo" argument has been deprecated since bug #389609, and is now removed.
Diffstat (limited to 'pym/_emerge/actions.py')
-rw-r--r--pym/_emerge/actions.py28
1 files changed, 2 insertions, 26 deletions
diff --git a/pym/_emerge/actions.py b/pym/_emerge/actions.py
index c403d8974..fb80173c4 100644
--- a/pym/_emerge/actions.py
+++ b/pym/_emerge/actions.py
@@ -87,21 +87,6 @@ if sys.hexversion >= 0x3000000:
else:
_unicode = unicode
-COWSAY_MOO = """
-
- Larry loves Gentoo (%s)
-
- _______________________
-< Have you mooed today? >
- -----------------------
- \ ^__^
- \ (oo)\_______
- (__)\ )\/\
- ||----w |
- || ||
-
-"""
-
def action_build(settings, trees, mtimedb,
myopts, myaction, myfiles, spinner):
@@ -3522,13 +3507,6 @@ def run_action(settings, trees, mtimedb, myaction, myopts, myfiles,
del mytrees, mydb
- if "moo" in myfiles:
- print(COWSAY_MOO % platform.system())
- msg = ("The above `emerge moo` display is deprecated. "
- "Please use `emerge --moo` instead.")
- for line in textwrap.wrap(msg, 50):
- print(" %s %s" % (colorize("WARN", "*"), line))
-
for x in myfiles:
ext = os.path.splitext(x)[1]
if (ext == ".ebuild" or ext == ".tbz2") and \
@@ -3538,10 +3516,8 @@ def run_action(settings, trees, mtimedb, myaction, myopts, myfiles,
break
root_config = trees[settings['EROOT']]['root_config']
- if myaction == "moo":
- print(COWSAY_MOO % platform.system())
- return os.EX_OK
- elif myaction == "list-sets":
+
+ if myaction == "list-sets":
writemsg_stdout("".join("%s\n" % s for s in sorted(root_config.sets)))
return os.EX_OK
elif myaction == "check-news":