summaryrefslogtreecommitdiffstats
path: root/pym/_emerge/actions.py
diff options
context:
space:
mode:
authorSebastian Luther <SebastianLuther@gmx.de>2010-09-21 10:10:41 +0200
committerZac Medico <zmedico@gentoo.org>2010-09-26 23:50:14 -0700
commite177e729bad3659cb2610f511928f90868bbebc3 (patch)
tree2016562a5a3154f4632cfae20b78baf98413b6ab /pym/_emerge/actions.py
parent5e94065640c219d9cf4ae1e632d638d88c007912 (diff)
downloadportage-e177e729bad3659cb2610f511928f90868bbebc3.tar.gz
portage-e177e729bad3659cb2610f511928f90868bbebc3.tar.bz2
portage-e177e729bad3659cb2610f511928f90868bbebc3.zip
reposyntax: Add support all over the place
Diffstat (limited to 'pym/_emerge/actions.py')
-rw-r--r--pym/_emerge/actions.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/pym/_emerge/actions.py b/pym/_emerge/actions.py
index 92eb18b74..52442878e 100644
--- a/pym/_emerge/actions.py
+++ b/pym/_emerge/actions.py
@@ -512,7 +512,7 @@ def action_config(settings, trees, myopts, myfiles):
else:
print("Configuring pkg...")
print()
- ebuildpath = trees[settings["ROOT"]]["vartree"].dbapi.findname(pkg)
+ ebuildpath = trees[settings["ROOT"]]["vartree"].dbapi.findname(pkg, myrepo=pkg.repo)
mysettings = portage.config(clone=settings)
vardb = trees[mysettings["ROOT"]]["vartree"].dbapi
debug = mysettings.get("PORTAGE_DEBUG") == "1"
@@ -1544,7 +1544,7 @@ def action_info(settings, trees, myopts, myfiles):
if pkg_type == "installed":
ebuildpath = vardb.findname(pkg.cpv)
elif pkg_type == "ebuild":
- ebuildpath = portdb.findname(pkg.cpv)
+ ebuildpath = portdb.findname(pkg.cpv, pkg.repo)
elif pkg_type == "binary":
tbz2_file = bindb.bintree.getname(pkg.cpv)
ebuild_file_name = pkg.cpv.split("/")[1] + ".ebuild"