summaryrefslogtreecommitdiffstats
path: root/pym/_emerge
diff options
context:
space:
mode:
authorDavid James <davidjames@google.com>2011-04-28 14:22:15 -0700
committerZac Medico <zmedico@gentoo.org>2011-05-04 12:37:16 -0700
commit9d8f999499bd0c6b11e016b99c32a997993275f3 (patch)
tree236567b3218dd2e8e4adfb9348a1f13e433af176 /pym/_emerge
parent329564d1ecaff96f894283200906c2c22a1ede7e (diff)
downloadportage-9d8f999499bd0c6b11e016b99c32a997993275f3.tar.gz
portage-9d8f999499bd0c6b11e016b99c32a997993275f3.tar.bz2
portage-9d8f999499bd0c6b11e016b99c32a997993275f3.zip
Move preinst/postinst_bsdflags from bash to py
Moving these commands from shell to Python helps avoid an unnecessary call to misc-functions.sh for the postinst_bsdflags. This improves performance. BUG=none TEST=Run emerge-x86-generic -eg --jobs=16 libchrome Change-Id: I0c2af50b4d2f7644cabac84fde7fe4d682010c69 Review URL: http://codereview.chromium.org/6676107
Diffstat (limited to 'pym/_emerge')
-rw-r--r--pym/_emerge/EbuildPhase.py7
1 files changed, 6 insertions, 1 deletions
diff --git a/pym/_emerge/EbuildPhase.py b/pym/_emerge/EbuildPhase.py
index e3270c893..1866f316d 100644
--- a/pym/_emerge/EbuildPhase.py
+++ b/pym/_emerge/EbuildPhase.py
@@ -17,7 +17,8 @@ portage.proxy.lazyimport.lazyimport(globals(),
'portage.package.ebuild.doebuild:_check_build_log,' + \
'_post_phase_cmds,_post_phase_userpriv_perms,' + \
'_post_src_install_chost_fix,' + \
- '_post_src_install_uid_fix'
+ '_post_src_install_uid_fix,_postinst_bsdflags,' + \
+ '_preinst_bsdflags'
)
from portage import os
from portage import StringIO
@@ -175,6 +176,10 @@ class EbuildPhase(CompositeTask):
if msg:
self.scheduler.output(msg,
log_path=self.settings.get("PORTAGE_LOG_FILE"))
+ elif self.phase == "preinst":
+ _preinst_bsdflags(settings)
+ elif self.phase == "postinst":
+ _postinst_bsdflags(settings)
post_phase_cmds = _post_phase_cmds.get(self.phase)
if post_phase_cmds is not None: