summaryrefslogtreecommitdiffstats
path: root/pym/portage/dbapi/vartree.py
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2009-10-07 23:30:04 +0000
committerZac Medico <zmedico@gentoo.org>2009-10-07 23:30:04 +0000
commitd557bea6d2c3bc311d03f5a4887092957586a16d (patch)
tree82529f35aa18d1d5b4256f70fd0b453bf2517a91 /pym/portage/dbapi/vartree.py
parent753da5d98709eb5705254bfe208918d683abc262 (diff)
downloadportage-d557bea6d2c3bc311d03f5a4887092957586a16d.tar.gz
portage-d557bea6d2c3bc311d03f5a4887092957586a16d.tar.bz2
portage-d557bea6d2c3bc311d03f5a4887092957586a16d.zip
Bug #287950 - Add support for FEATURES=fail-clean which is useful for cleaning
up temp files on tmpfs after build failures with --keep-going. svn path=/main/trunk/; revision=14517
Diffstat (limited to 'pym/portage/dbapi/vartree.py')
-rw-r--r--pym/portage/dbapi/vartree.py5
1 files changed, 4 insertions, 1 deletions
diff --git a/pym/portage/dbapi/vartree.py b/pym/portage/dbapi/vartree.py
index 5971ca647..c103cbd8d 100644
--- a/pym/portage/dbapi/vartree.py
+++ b/pym/portage/dbapi/vartree.py
@@ -4349,7 +4349,10 @@ class dblink(object):
# Process ebuild logfiles
elog_process(self.mycpv, self.settings, phasefilter=filter_mergephases)
- if retval == os.EX_OK and "noclean" not in self.settings.features:
+ if 'noclean' not in self.settings.features and \
+ (retval == os.EX_OK or \
+ ('fail-clean' in self.settings.features and \
+ os.path.isdir(self.settings['PORTAGE_BUILDDIR']))):
if myebuild is None:
myebuild = os.path.join(inforoot, self.pkg + ".ebuild")