summaryrefslogtreecommitdiffstats
path: root/pym/portage/dbapi/vartree.py
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2011-05-24 21:07:31 -0700
committerZac Medico <zmedico@gentoo.org>2011-05-24 21:07:31 -0700
commitd755309c28a03302e4906a3375187d3f23154d43 (patch)
treedfb59e672d5403be62a11f24cd02898ca6617153 /pym/portage/dbapi/vartree.py
parentfaa536f437c445c3d2eb06c791b1492101474cc9 (diff)
downloadportage-d755309c28a03302e4906a3375187d3f23154d43.tar.gz
portage-d755309c28a03302e4906a3375187d3f23154d43.tar.bz2
portage-d755309c28a03302e4906a3375187d3f23154d43.zip
cleanrm: handle UnsupportedAPIException
Diffstat (limited to 'pym/portage/dbapi/vartree.py')
-rw-r--r--pym/portage/dbapi/vartree.py7
1 files changed, 5 insertions, 2 deletions
diff --git a/pym/portage/dbapi/vartree.py b/pym/portage/dbapi/vartree.py
index 5aec973eb..e29d70e20 100644
--- a/pym/portage/dbapi/vartree.py
+++ b/pym/portage/dbapi/vartree.py
@@ -1783,8 +1783,11 @@ class dblink(object):
# even though it won't really be sourced.
myebuildpath = os.path.join(self.dbdir,
self.pkg + ".ebuild")
- doebuild_environment(myebuildpath, "cleanrm",
- settings=self.settings, db=self.vartree.dbapi)
+ try:
+ doebuild_environment(myebuildpath, "cleanrm",
+ settings=self.settings, db=self.vartree.dbapi)
+ except UnsupportedAPIException:
+ pass
phase = EbuildPhase(background=background,
phase="cleanrm", scheduler=scheduler,
settings=self.settings)