summaryrefslogtreecommitdiffstats
path: root/pym
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2006-05-27 01:52:29 +0000
committerZac Medico <zmedico@gentoo.org>2006-05-27 01:52:29 +0000
commit6b767b929ffc948017446be9b9c5c5619f48b4cf (patch)
treed56c81d27570546babb5b0f0a4197dd8b3298819 /pym
parent3c838cc112da8daa1dab6efe8a3d048baab934b0 (diff)
downloadportage-6b767b929ffc948017446be9b9c5c5619f48b4cf.tar.gz
portage-6b767b929ffc948017446be9b9c5c5619f48b4cf.tar.bz2
portage-6b767b929ffc948017446be9b9c5c5619f48b4cf.zip
Add noiselevel=-1 to writemsg calls for legitimate errors in merge and unmerge phases so that important errors are printed even when --quiet is used.
svn path=/main/trunk/; revision=3425
Diffstat (limited to 'pym')
-rw-r--r--pym/portage.py12
1 files changed, 6 insertions, 6 deletions
diff --git a/pym/portage.py b/pym/portage.py
index 43b21f06f..836641d10 100644
--- a/pym/portage.py
+++ b/pym/portage.py
@@ -5847,7 +5847,7 @@ class dblink:
mydbapi=self.vartree.dbapi, vartree=self.vartree)
# XXX: Decide how to handle failures here.
if a != 0:
- writemsg("!!! FAILED prerm: "+str(a)+"\n")
+ writemsg("!!! FAILED prerm: "+str(a)+"\n", noiselevel=-1)
sys.exit(123)
if pkgfiles:
@@ -6009,7 +6009,7 @@ class dblink:
vartree=self.vartree)
# XXX: Decide how to handle failures here.
if a != 0:
- writemsg("!!! FAILED postrm: "+str(a)+"\n")
+ writemsg("!!! FAILED postrm: "+str(a)+"\n", noiselevel=-1)
sys.exit(123)
doebuild(myebuildpath, "cleanrm", self.myroot, self.settings,
tree="vartree", mydbapi=self.vartree.dbapi,
@@ -6238,7 +6238,7 @@ class dblink:
# XXX: Decide how to handle failures here.
if a != 0:
- writemsg("!!! FAILED postinst: "+str(a)+"\n")
+ writemsg("!!! FAILED postinst: "+str(a)+"\n", noiselevel=-1)
sys.exit(123)
downgrade = False
@@ -6294,8 +6294,8 @@ class dblink:
writemsg(red("!!! as existing is not capable of being stat'd. If you are using an\n"))
writemsg(red("!!! experimental kernel, please boot into a stable one, force an fsck,\n"))
writemsg(red("!!! and ensure your filesystem is in a sane state. ")+bold("'shutdown -Fr now'\n"))
- writemsg(red("!!! File: ")+str(mysrc)+"\n")
- writemsg(red("!!! Error: ")+str(e)+"\n")
+ writemsg(red("!!! File: ")+str(mysrc)+"\n", noiselevel=-1)
+ writemsg(red("!!! Error: ")+str(e)+"\n", noiselevel=-1)
sys.exit(1)
except Exception, e:
writemsg("\n")
@@ -6380,7 +6380,7 @@ class dblink:
if not os.access(mydest, os.W_OK):
pkgstuff = pkgsplit(self.pkg)
- writemsg("\n!!! Cannot write to '"+mydest+"'.\n")
+ writemsg("\n!!! Cannot write to '"+mydest+"'.\n", noiselevel=-1)
writemsg("!!! Please check permissions and directories for broken symlinks.\n")
writemsg("!!! You may start the merge process again by using ebuild:\n")
writemsg("!!! ebuild "+self.settings["PORTDIR"]+"/"+self.cat+"/"+pkgstuff[0]+"/"+self.pkg+".ebuild merge\n")