summaryrefslogtreecommitdiffstats
path: root/pym
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2010-08-09 23:38:38 -0700
committerZac Medico <zmedico@gentoo.org>2010-08-09 23:38:38 -0700
commit77c2db9850be29d1cd94c58cbc2e2b05e03bc9d2 (patch)
tree30391e1f9bf44ffee56306242d939189ee1d9db1 /pym
parentfe2a1cd25ed779ac1a09b9b5c076c61981a46158 (diff)
downloadportage-77c2db9850be29d1cd94c58cbc2e2b05e03bc9d2.tar.gz
portage-77c2db9850be29d1cd94c58cbc2e2b05e03bc9d2.tar.bz2
portage-77c2db9850be29d1cd94c58cbc2e2b05e03bc9d2.zip
Relocate attributes from AbstractEbuildProcess to subclasses that use
them, since EbuildSpawnProcess doesn't use the attributes.
Diffstat (limited to 'pym')
-rw-r--r--pym/_emerge/AbstractEbuildProcess.py2
-rw-r--r--pym/_emerge/EbuildProcess.py2
-rw-r--r--pym/_emerge/MiscFunctionsProcess.py2
3 files changed, 3 insertions, 3 deletions
diff --git a/pym/_emerge/AbstractEbuildProcess.py b/pym/_emerge/AbstractEbuildProcess.py
index 293251323..302d34403 100644
--- a/pym/_emerge/AbstractEbuildProcess.py
+++ b/pym/_emerge/AbstractEbuildProcess.py
@@ -8,7 +8,7 @@ from portage.util._pty import _create_pty_or_pipe
class AbstractEbuildProcess(SpawnProcess):
- __slots__ = ('phase', 'pkg', 'settings',)
+ __slots__ = ('settings',)
def _pipe(self, fd_pipes):
stdout_pipe = fd_pipes.get(1)
diff --git a/pym/_emerge/EbuildProcess.py b/pym/_emerge/EbuildProcess.py
index bf7af4b9d..a0ef2357a 100644
--- a/pym/_emerge/EbuildProcess.py
+++ b/pym/_emerge/EbuildProcess.py
@@ -8,7 +8,7 @@ from portage.package.ebuild.doebuild import doebuild, \
class EbuildProcess(AbstractEbuildProcess):
- __slots__ = ('tree',)
+ __slots__ = ('phase', 'pkg', 'tree',)
def _start(self):
# Don't open the log file during the clean phase since the
diff --git a/pym/_emerge/MiscFunctionsProcess.py b/pym/_emerge/MiscFunctionsProcess.py
index c0d40a197..c66beb2c2 100644
--- a/pym/_emerge/MiscFunctionsProcess.py
+++ b/pym/_emerge/MiscFunctionsProcess.py
@@ -12,7 +12,7 @@ class MiscFunctionsProcess(AbstractEbuildProcess):
Spawns misc-functions.sh with an existing ebuild environment.
"""
- __slots__ = ('commands',)
+ __slots__ = ('commands', 'phase', 'pkg',)
def _start(self):
settings = self.settings