summaryrefslogtreecommitdiffstats
path: root/pym
diff options
context:
space:
mode:
authorDavid James <davidjames@google.com>2011-04-28 14:22:15 -0700
committerZac Medico <zmedico@gentoo.org>2011-05-04 12:37:16 -0700
commit9d8f999499bd0c6b11e016b99c32a997993275f3 (patch)
tree236567b3218dd2e8e4adfb9348a1f13e433af176 /pym
parent329564d1ecaff96f894283200906c2c22a1ede7e (diff)
downloadportage-9d8f999499bd0c6b11e016b99c32a997993275f3.tar.gz
portage-9d8f999499bd0c6b11e016b99c32a997993275f3.tar.bz2
portage-9d8f999499bd0c6b11e016b99c32a997993275f3.zip
Move preinst/postinst_bsdflags from bash to py
Moving these commands from shell to Python helps avoid an unnecessary call to misc-functions.sh for the postinst_bsdflags. This improves performance. BUG=none TEST=Run emerge-x86-generic -eg --jobs=16 libchrome Change-Id: I0c2af50b4d2f7644cabac84fde7fe4d682010c69 Review URL: http://codereview.chromium.org/6676107
Diffstat (limited to 'pym')
-rw-r--r--pym/_emerge/EbuildPhase.py7
-rw-r--r--pym/portage/package/ebuild/doebuild.py37
2 files changed, 29 insertions, 15 deletions
diff --git a/pym/_emerge/EbuildPhase.py b/pym/_emerge/EbuildPhase.py
index e3270c893..1866f316d 100644
--- a/pym/_emerge/EbuildPhase.py
+++ b/pym/_emerge/EbuildPhase.py
@@ -17,7 +17,8 @@ portage.proxy.lazyimport.lazyimport(globals(),
'portage.package.ebuild.doebuild:_check_build_log,' + \
'_post_phase_cmds,_post_phase_userpriv_perms,' + \
'_post_src_install_chost_fix,' + \
- '_post_src_install_uid_fix'
+ '_post_src_install_uid_fix,_postinst_bsdflags,' + \
+ '_preinst_bsdflags'
)
from portage import os
from portage import StringIO
@@ -175,6 +176,10 @@ class EbuildPhase(CompositeTask):
if msg:
self.scheduler.output(msg,
log_path=self.settings.get("PORTAGE_LOG_FILE"))
+ elif self.phase == "preinst":
+ _preinst_bsdflags(settings)
+ elif self.phase == "postinst":
+ _postinst_bsdflags(settings)
post_phase_cmds = _post_phase_cmds.get(self.phase)
if post_phase_cmds is not None:
diff --git a/pym/portage/package/ebuild/doebuild.py b/pym/portage/package/ebuild/doebuild.py
index f353166d7..2a4079109 100644
--- a/pym/portage/package/ebuild/doebuild.py
+++ b/pym/portage/package/ebuild/doebuild.py
@@ -1233,14 +1233,10 @@ _post_phase_cmds = {
"install_symlink_html_docs"],
"preinst" : [
- "preinst_bsdflags",
"preinst_sfperms",
"preinst_selinux_labels",
"preinst_suid_scan",
- "preinst_mask"],
-
- "postinst" : [
- "postinst_bsdflags"]
+ "preinst_mask"]
}
def _post_phase_userpriv_perms(mysettings):
@@ -1392,6 +1388,27 @@ _vdb_use_conditional_keys = ('DEPEND', 'LICENSE', 'PDEPEND',
'PROPERTIES', 'PROVIDE', 'RDEPEND', 'RESTRICT',)
_vdb_use_conditional_atoms = frozenset(['DEPEND', 'PDEPEND', 'RDEPEND'])
+def _preinst_bsdflags(mysettings):
+ if bsd_chflags:
+ # Save all the file flags for restoration later.
+ os.system("mtree -c -p %s -k flags > %s" % \
+ (_shell_quote(mysettings["D"]),
+ _shell_quote(os.path.join(mysettings["T"], "bsdflags.mtree"))))
+
+ # Remove all the file flags to avoid EPERM errors.
+ os.system("chflags -R noschg,nouchg,nosappnd,nouappnd %s" % \
+ (_shell_quote(mysettings["D"]),))
+ os.system("chflags -R nosunlnk,nouunlnk %s 2>/dev/null" % \
+ (_shell_quote(mysettings["D"]),))
+
+
+def _postinst_bsdflags(mysettings):
+ if bsd_chflags:
+ # Restore all of the flags saved above.
+ os.system("mtree -e -p %s -U -k flags < %s > /dev/null" % \
+ (_shell_quote(mysettings["D"]),
+ _shell_quote(os.path.join(mysettings["T"], "bsdflags.mtree"))))
+
def _post_src_install_uid_fix(mysettings, out):
"""
Files in $D with user and group bits that match the "portage"
@@ -1406,15 +1423,7 @@ def _post_src_install_uid_fix(mysettings, out):
inst_uid = int(mysettings["PORTAGE_INST_UID"])
inst_gid = int(mysettings["PORTAGE_INST_GID"])
- if bsd_chflags:
- # Temporarily remove all of the flags in order to avoid EPERM errors.
- os.system("mtree -c -p %s -k flags > %s" % \
- (_shell_quote(mysettings["D"]),
- _shell_quote(os.path.join(mysettings["T"], "bsdflags.mtree"))))
- os.system("chflags -R noschg,nouchg,nosappnd,nouappnd %s" % \
- (_shell_quote(mysettings["D"]),))
- os.system("chflags -R nosunlnk,nouunlnk %s 2>/dev/null" % \
- (_shell_quote(mysettings["D"]),))
+ _preinst_bsdflags(mysettings)
destdir = mysettings["D"]
unicode_errors = []