summaryrefslogtreecommitdiffstats
path: root/pym
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2011-10-20 22:40:06 +0200
committerFabian Groffen <grobian@gentoo.org>2011-10-20 22:40:06 +0200
commit7a2867753bca22f6655ab4760950c0a8be6c8ef7 (patch)
treea61536b46231bb514eb65e0319c6dc8d31088752 /pym
parentdb3e214be456864225eecb37a9c941fd1689bee0 (diff)
parent68414e9ffe4c05a0a0e81734b80db61e2782937c (diff)
downloadportage-7a2867753bca22f6655ab4760950c0a8be6c8ef7.tar.gz
portage-7a2867753bca22f6655ab4760950c0a8be6c8ef7.tar.bz2
portage-7a2867753bca22f6655ab4760950c0a8be6c8ef7.zip
Merge branch 'master' of git+ssh://git.overlays.gentoo.org/proj/portage
Diffstat (limited to 'pym')
-rw-r--r--pym/portage/tests/repoman/test_simple.py18
1 files changed, 14 insertions, 4 deletions
diff --git a/pym/portage/tests/repoman/test_simple.py b/pym/portage/tests/repoman/test_simple.py
index 172c22d93..68681b33f 100644
--- a/pym/portage/tests/repoman/test_simple.py
+++ b/pym/portage/tests/repoman/test_simple.py
@@ -42,6 +42,15 @@ class SimpleRepomanTestCase(TestCase):
# $Header: $
""" % time.gmtime().tm_year
+ repo_configs = {
+ "test_repo": {
+ "layout.conf":
+ (
+ "update-changelog = true",
+ ),
+ }
+ }
+
profiles = (
("x86", "default/linux/x86/test_profile", "stable"),
)
@@ -91,7 +100,8 @@ class SimpleRepomanTestCase(TestCase):
("flag", "Description of how USE='flag' affects packages"),
)
- playground = ResolverPlayground(ebuilds=ebuilds, debug=debug)
+ playground = ResolverPlayground(ebuilds=ebuilds,
+ repo_configs=repo_configs, debug=debug)
settings = playground.settings
eprefix = settings["EPREFIX"]
eroot = settings["EROOT"]
@@ -128,13 +138,13 @@ class SimpleRepomanTestCase(TestCase):
("", git_cmd + ("commit", "-a", "-m", "add whole repo")),
("", cp_cmd + (test_ebuild, test_ebuild[:-8] + "2.ebuild")),
("", git_cmd + ("add", test_ebuild[:-8] + "2.ebuild")),
- ("", repoman_cmd + ("commit", "--echangelog=y", "-m", "bump to version 2")),
+ ("", repoman_cmd + ("commit", "-m", "bump to version 2")),
("", cp_cmd + (test_ebuild, test_ebuild[:-8] + "3.ebuild")),
("", git_cmd + ("add", test_ebuild[:-8] + "3.ebuild")),
- ("dev-libs", repoman_cmd + ("commit", "--echangelog=y", "-m", "bump to version 3")),
+ ("dev-libs", repoman_cmd + ("commit", "-m", "bump to version 3")),
("", cp_cmd + (test_ebuild, test_ebuild[:-8] + "4.ebuild")),
("", git_cmd + ("add", test_ebuild[:-8] + "4.ebuild")),
- ("dev-libs/A", repoman_cmd + ("commit", "--echangelog=y", "-m", "bump to version 4")),
+ ("dev-libs/A", repoman_cmd + ("commit", "-m", "bump to version 4")),
)
pythonpath = os.environ.get("PYTHONPATH")