summaryrefslogtreecommitdiffstats
path: root/pym
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2010-03-02 20:56:25 +0000
committerZac Medico <zmedico@gentoo.org>2010-03-02 20:56:25 +0000
commite751a4d565d9e23a1beadaabb71870040e40eca8 (patch)
tree08240fc8322ba0ae87746ca3d50667a023bc02c7 /pym
parent21d82e8e0c0d4482672fc170cdc89f5adcde010f (diff)
downloadportage-e751a4d565d9e23a1beadaabb71870040e40eca8.tar.gz
portage-e751a4d565d9e23a1beadaabb71870040e40eca8.tar.bz2
portage-e751a4d565d9e23a1beadaabb71870040e40eca8.zip
Use lazy import for portage.Manifest. (trunk r15426)
svn path=/main/branches/2.1.7/; revision=15648
Diffstat (limited to 'pym')
-rw-r--r--pym/portage/__init__.py3
1 files changed, 1 insertions, 2 deletions
diff --git a/pym/portage/__init__.py b/pym/portage/__init__.py
index 28a06d786..aaa3f0616 100644
--- a/pym/portage/__init__.py
+++ b/pym/portage/__init__.py
@@ -99,6 +99,7 @@ try:
'portage.locks',
'portage.locks:lockdir,lockfile,unlockdir,unlockfile',
'portage.mail',
+ 'portage.manifest:Manifest',
'portage.output',
'portage.output:bold,colorize',
'portage.package.ebuild.config:autouse,best_from_dict,' + \
@@ -312,8 +313,6 @@ except (ImportError, OSError) as e:
selinux = None
_selinux_merge = None
-from portage.manifest import Manifest
-
# ===========================================================================
# END OF IMPORTS -- END OF IMPORTS -- END OF IMPORTS -- END OF IMPORTS -- END
# ===========================================================================