summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xbin/repoman16
1 files changed, 12 insertions, 4 deletions
diff --git a/bin/repoman b/bin/repoman
index 695141ca1..09a340f4e 100755
--- a/bin/repoman
+++ b/bin/repoman
@@ -1042,12 +1042,20 @@ for x in scanlist:
Ebuilds that inherit a "Live" eclasss (darcs,subversion,git,cvs,etc..) should
not be allowed to be marked stable
"""
- if set(["darcs","cvs","subversion","git"]).intersection(myaux["INHERITED"].split()):
- bad_stable_keywords = [keyword for keyword in myaux["KEYWORDS"].split() if not keyword.startswith("~") and not keyword.startswith("-")]
+ if set(["darcs","cvs","subversion","git"]).intersection(
+ myaux["INHERITED"].split()):
+ bad_stable_keywords = []
+ for keyword in myaux["KEYWORDS"].split():
+ if not keyword.startswith("~") and \
+ not keyword.startswith("-"):
+ bad_stable_keywords.append(keyword)
+ del keyword
if bad_stable_keywords:
stats["LIVEVCS.stable"] += 1
- fails["LIVEVCS.stable"].append(x+"/"+y+".ebuild with stable keywords:%s " % bad_stable_keywords)
- del bad_stable_keywords
+ fails["LIVEVCS.stable"].append(
+ x + "/" + y + ".ebuild with stable keywords:%s " % \
+ bad_stable_keywords)
+ del bad_stable_keywords
if "--ignore-arches" in myoptions:
arches = [[repoman_settings["ARCH"], repoman_settings["ARCH"],