summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xbin/repoman10
1 files changed, 1 insertions, 9 deletions
diff --git a/bin/repoman b/bin/repoman
index b94c6459e..c68beb68e 100755
--- a/bin/repoman
+++ b/bin/repoman
@@ -972,7 +972,7 @@ for x in scanlist:
fails["ebuild.namenomatch"].append(x+"/"+y+".ebuild")
continue
try:
- myaux=portage.db["/"]["porttree"].dbapi.aux_get(catdir+"/"+y,allvars)
+ myaux = dict( zip(allvars, portage.db["/"]["porttree"].dbapi.aux_get(catdir+"/"+y, allvars ) )
except KeyError:
stats["ebuild.syntax"]=stats["ebuild.syntax"]+1
fails["ebuild.syntax"].append(x+"/"+y+".ebuild")
@@ -982,14 +982,6 @@ for x in scanlist:
fails["ebuild.output"].append(x+"/"+y+".ebuild")
continue
- mynewaux = {}
- for idx in range(len(allvars)):
- if idx < len(myaux):
- mynewaux[allvars[idx]] = myaux[idx]
- else:
- mynewaux[allvars[idx]] = ""
- myaux = mynewaux
-
# Test for negative logic and bad words in the RESTRICT var.
#for x in myaux[allvars.index("RESTRICT")].split():
# if x.startswith("no"):