summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xbin/ebuild.sh15
-rwxr-xr-xbin/isolated-functions.sh1
2 files changed, 10 insertions, 6 deletions
diff --git a/bin/ebuild.sh b/bin/ebuild.sh
index d1e2e8fd0..74a848a35 100755
--- a/bin/ebuild.sh
+++ b/bin/ebuild.sh
@@ -1802,11 +1802,7 @@ if ! hasq "$EBUILD_PHASE" clean cleanrm depend && \
unset PORTAGE_SANDBOX_ON
fi
-if ! hasq "$EBUILD_PHASE" clean cleanrm ; then
-if [[ $EBUILD_PHASE = depend || ! -f $T/environment || \
- -f $PORTAGE_BUILDDIR/.ebuild_changed ]] || \
- hasq noauto $FEATURES ; then
-
+_source_ebuild() {
# The bashrcs get an opportunity here to set aliases that will be expanded
# during sourcing of ebuilds and eclasses.
source_all_bashrcs
@@ -1845,7 +1841,14 @@ if [[ $EBUILD_PHASE = depend || ! -f $T/environment || \
# This needs to be exported since prepstrip is a separate shell script.
[[ -n $QA_PRESTRIPPED ]] && export QA_PRESTRIPPED
-fi
+}
+
+if ! hasq "$EBUILD_PHASE" clean cleanrm ; then
+ if [[ $EBUILD_PHASE = depend || ! -f $T/environment || \
+ -f $PORTAGE_BUILDDIR/.ebuild_changed ]] || \
+ hasq noauto $FEATURES ; then
+ _source_ebuild
+ fi
fi
# Set default EAPI if necessary, so that most
diff --git a/bin/isolated-functions.sh b/bin/isolated-functions.sh
index 9abfc308a..ccef19ed2 100755
--- a/bin/isolated-functions.sh
+++ b/bin/isolated-functions.sh
@@ -518,6 +518,7 @@ save_ebuild_env() {
source_all_bashrcs ebuild_main \
ebuild_phase ebuild_phase_with_hooks \
_ebuild_arg_to_phase _ebuild_phase_funcs default \
+ _source_ebuild \
${QA_INTERCEPTORS}
# portage config variables and variables set directly by portage