summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xbin/repoman3
-rw-r--r--pym/repoman/errors.py2
2 files changed, 3 insertions, 2 deletions
diff --git a/bin/repoman b/bin/repoman
index 5a5455bbd..472fb3278 100755
--- a/bin/repoman
+++ b/bin/repoman
@@ -1393,7 +1393,8 @@ for x in scanlist:
errors = check.Run()
for e in errors:
stats[check.repoman_check_name] += 1
- fails[check.repoman_check_name].append(x + '/' + y + '.ebuild: %s' % e)
+ fails[check.repoman_check_name].append(
+ x + '/' + y + '.ebuild: %s' % e[1] % e[0])
del check, errors, path, contents, myear
if options.force:
diff --git a/pym/repoman/errors.py b/pym/repoman/errors.py
index 3b3b3c179..d1aad1d8a 100644
--- a/pym/repoman/errors.py
+++ b/pym/repoman/errors.py
@@ -10,5 +10,5 @@ LEADING_SPACES_ERROR = 'Ebuild contains leading spaces on line: %d'
TRAILING_WHITESPACE_ERROR = 'Trailing whitespace error on line: %d'
READONLY_ASSIGNMENT_ERROR = 'Ebuild contains assignment to read-only variable on line: %d'
MISSING_QUOTES_ERROR = 'Unquoted Variable on line: %d'
-NESTED_DIE_ERROR = 'Ebuild calls die in a subshell'
+NESTED_DIE_ERROR = 'Ebuild calls die in a subshell on line: %d'
REDUNDANT_CD_S_ERROR = 'Ebuild has redundant cd ${S} statement on line: %d'