summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xbin/misc-functions.sh12
-rw-r--r--pym/portage/__init__.py3
2 files changed, 11 insertions, 4 deletions
diff --git a/bin/misc-functions.sh b/bin/misc-functions.sh
index 1c79822d2..04c73fc65 100755
--- a/bin/misc-functions.sh
+++ b/bin/misc-functions.sh
@@ -523,7 +523,9 @@ dyn_package() {
}
dyn_spec() {
- tar czf "/usr/src/redhat/SOURCES/${PF}.tar.gz" "${O}/${PF}.ebuild" "${O}/files" || die "Failed to create base rpm tarball."
+ tar czf "/usr/src/rpm/SOURCES/${PF}.tar.gz" \
+ "${O}/${PF}.ebuild" "${O}/files" || \
+ die "Failed to create base rpm tarball."
cat <<__END1__ > ${PF}.spec
Summary: ${DESCRIPTION}
@@ -555,11 +557,13 @@ __END1__
}
dyn_rpm() {
- addwrite /usr/src/redhat/
- addwrite ${RPMDIR}
+ addwrite /usr/src/rpm
+ addwrite "${RPMDIR}"
dyn_spec
rpmbuild -bb "${PF}.spec" || die "Failed to integrate rpm spec file"
- install -D "/usr/src/redhat/RPMS/i386/${PN}-${PV}-${PR}.i386.rpm" "${RPMDIR}/${CATEGORY}/${PN}-${PV}-${PR}.rpm" || die "Failed to move rpm"
+ install -D "/usr/src/rpm/RPMS/i386/${PN}-${PV}-${PR}.i386.rpm" \
+ "${RPMDIR}/${CATEGORY}/${PN}-${PV}-${PR}.rpm" || \
+ die "Failed to move rpm"
}
if [ -n "${MISC_FUNCTIONS_ARGS}" ]; then
diff --git a/pym/portage/__init__.py b/pym/portage/__init__.py
index 1f6d49c22..e11b8f419 100644
--- a/pym/portage/__init__.py
+++ b/pym/portage/__init__.py
@@ -3342,6 +3342,9 @@ def doebuild_environment(myebuild, mydo, myroot, mysettings, debug, use_cache, m
mysettings["PF"] = mypv
mysettings["PORTDIR"] = os.path.realpath(mysettings["PORTDIR"])
+ mysettings["DISTDIR"] = os.path.realpath(mysettings["DISTDIR"])
+ mysettings["RPMDIR"] = os.path.realpath(mysettings["RPMDIR"])
+
mysettings["ECLASSDIR"] = mysettings["PORTDIR"]+"/eclass"
mysettings["SANDBOX_LOG"] = mycpv.replace("/", "_-_")