summaryrefslogtreecommitdiffstats
path: root/bin/ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'bin/ebuild')
-rwxr-xr-xbin/ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/bin/ebuild b/bin/ebuild
index 90c599e26..ebb96f0bb 100755
--- a/bin/ebuild
+++ b/bin/ebuild
@@ -82,6 +82,12 @@ if portage.settings["NOCOLOR"] in ("yes","true") or not sys.stdout.isatty():
portage.output.nocolor()
ebuild = pargs.pop(0)
+
+if not ebuild.endswith(".ebuild"):
+ portage.writemsg("'%s' does not end with '.ebuild'.\n" % \
+ (ebuild,), noiselevel=-1)
+ sys.exit(1)
+
if not os.path.isabs(ebuild):
mycwd = os.getcwd()
# Try to get the non-canonical path from the PWD evironment variable, since