summaryrefslogtreecommitdiffstats
path: root/bin/portageq
diff options
context:
space:
mode:
Diffstat (limited to 'bin/portageq')
-rwxr-xr-xbin/portageq8
1 files changed, 5 insertions, 3 deletions
diff --git a/bin/portageq b/bin/portageq
index fa713889a..a13ca998c 100755
--- a/bin/portageq
+++ b/bin/portageq
@@ -461,9 +461,11 @@ def all_best_visible(argv):
"""<root>
Returns all best_visible packages (without .ebuild).
"""
- if (len(argv) < 1):
- print("ERROR: insufficient parameters!")
-
+ if len(argv) < 1:
+ sys.stderr.write("ERROR: insufficient parameters!\n")
+ sys.stderr.flush()
+ return 2
+
#print portage.db[argv[0]]["porttree"].dbapi.cp_all()
for pkg in portage.db[argv[0]]["porttree"].dbapi.cp_all():
mybest=portage.best(portage.db[argv[0]]["porttree"].dbapi.match(pkg))