summaryrefslogtreecommitdiffstats
path: root/bin/repoman
diff options
context:
space:
mode:
Diffstat (limited to 'bin/repoman')
-rwxr-xr-xbin/repoman10
1 files changed, 8 insertions, 2 deletions
diff --git a/bin/repoman b/bin/repoman
index 1e2f54864..3eef5c29d 100755
--- a/bin/repoman
+++ b/bin/repoman
@@ -999,8 +999,14 @@ for x in scanlist:
#for x in myaux[allvars.index("RESTRICT")].split():
# if x.startswith("no"):
# print "Bad RESTRICT value: %s" % x
-
- myaux["PROVIDE"] = portage_dep.use_reduce(portage_dep.paren_reduce(myaux["PROVIDE"]), matchall=1)
+ try:
+ myaux["PROVIDE"] = portage_dep.use_reduce(
+ portage_dep.paren_reduce(myaux["PROVIDE"]), matchall=1)
+ except portage_exception.InvalidDependString, e:
+ stats["PROVIDE.syntax"] = stats["PROVIDE.syntax"] + 1
+ fails["PROVIDE.syntax"].append(mykey+".ebuild PROVIDE: "+str(e))
+ del e
+ continue
myaux["PROVIDE"] = " ".join(portage.flatten(myaux["PROVIDE"]))
for myprovide in myaux["PROVIDE"].split():
prov_cp = portage.dep_getkey(myprovide)